[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Trapped in 8-bit color



I have installed RH 5.1 on an Alpha PC164LX which runs a Matrox Millennium II PCI video card w/ 8MB RAM (in a   
64-bit slot on the mobo).  Box includes a Buslogic 958 UW SCSI controller, a 4.5 GB Seagate Cheetah HD, Kingston   
NIC w/ DEC Tulip 10/100 ethernet card, 128 MB RAM, and a SB16 sound card I haven't even begun to fiddle with.    
The Matrox Mill II PCI video card drives a 21" Idek Iiyama (30-80 horiz; 50-90 vert)  to 1600 x 1200 (and on another   
box running SuSE 5.2 Linux or OS2, the same card and monitor happily display 16M colors at 1280 x 1024, which is   
my preferred resolution on this monitor).  I have installed all the RH 5.1 upgrades (as of today) for the Alpha.   
 
Xconfigurator correctly identifies the video card by name and I then take the "custom" monitor option and choose a   
monitor which can do 1280 x 1024 @ 60 Hz or 72 Hz.  Xconfigurator then recommends I run at 1024 x 768 at 32-bit   
color.   Great!  But, if I take that recommendation, the server will not start, and on occasion it has locked up the   
box to the point of my needing to cycle power to get it back.  After a few experiences like that, I was back to   
rejecting the recommendation and choosing all of the resolution and color depth options Xconfigurator presented.    
Only the 8-bit options run. On some occasions, I have edited XF86Config to correct the vertical and horizontal to   
match _exactly the ranges (30-80 and 50-90) recited by the monitor's manual, and I have always inserted the   
relevant video memory info (VideoRam 8192) in the section where the video card is described.  Oh, yes; RTFM?    
Yes!  I have been throught man page on Xconfigurator many times looking for useful ideas and options and I have   
edited XF86Config almost as many times.  I get the resolutions I want (up to 1600 x 1200, no prob); therefore, i infer   
XF86Config's monitor info is OK.  However, I do not get more than 8-bit color, and if I edit XF86Config to allow no   
8-bit options, the server fails.   
 
A clue:  when I run SuperProbe on the card, it always misidentifies the chipset as an Oak IO087 or something with   
256k RAM.  Therefore, I suspect the prob lies with XConfigurator ignoring the info I am putting into XF86Config   
and/or misreading or failing to reset some other file correctly as to VideoRam or chipset on the video card.  But,   
which file, and where? 
 
My experience with the same card and monitor on an intel box shows X can do the job, the monitor can do it and   
the card can do it.   The prob seems to be in the RH 5.1 for Alpha. 
 
Any ideas how to get RH 5.1 (w/updates) to run in color above 8-bit? Is there yet another file to edit? Something   
else to try?   
 
Thanks in advance for any suggestions. 

Regards,

Jep
-----------------------------------
Penguin inside!  Now THAT'S Cool!
-----------------------------------

cc: Joe Barr <joe@dweeb.pjprimer.com>
    Robb Romans <rr44607@swt.edu>
    Stuart Green <stugreen@bga.com>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []