[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] EMC Clariion ghost devices



On ven, 2005-07-29 at 15:28 -0700, Joel Becker wrote:
> Christophe,
> 	I've just tried using the multipath-tools (SLES9 SP2,
> multipath-tools-0.4.4-0.22) with my EMC clariion.  Now, this clariion is
> an active/passive system, and the second path is showing a ghost LUN 0
> (this is expected).
> 	During normal boot, the device (/dev/sdap) returns an I/O error
> when the kernel tries to get the partition table.  No problem.  If later
> someone scans the disk, they get an I/O error.  No problem.
> 	Then I fire up multipathd and multipath.  Multipath creates a dm
> device for the ghost, and tries to run kpartx on it.  That kpartx hangs.
> In fact, I don't know how, but it ends up in a frozen I/O state.  It's
> unkillable.  I'd expect an I/O error, but no, it just plain doesn't
> exit.  Ditto any other access to the associated dm.
> 	Now, is this a dm problem (the device not seeing the error and
> returning it)?  Is it a multipath problem (multipath should notice the
> ghost and not try to dm it)?  Is it a configuration problem (I should
> somehow know which name the ghost got, and configure multipath to ignore
> it)?

/sbin/multipath sure shouldn't create a multipath map with just ghost
paths in it. If it is the case, some paths' wwid must be wrong. May be
due to scsi_id inconsistencies ?

You can try and verify that with 'multipath -v4', reading the "all
paths" section.

I hope Lars will react on this one as he has the hardware at hand ...

Regards,
-- 
christophe varoqui <christophe varoqui free fr>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]