[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] Unable to use multipath with LVM2



On 2005-04-30T09:29:21, Magni Fabrizio <Fabrizio Magni rasnet it> wrote:

> Hello,
> I'm new to multipath and I'm having an hard time configuring the one
> shipped with my distribution. The version is "multipath v0.3.6".

It'd be helpful if you actually reported which distribution you're
talking about ;-)

But looking at your version, I guess you might be running SLES9. In
which case SP2 should help address your troubles:
http://portal.suse.com/sdb/en/2005/04/sles_multipathing.html

Please try and get access to the beta via your support contact.

> If I insert aliases in multipath.conf and modify udev.rules I can see
> symbolick links wichi can be used in failover or multibus (tested) but
> they are not seen by the LVM2 (even modifying the filter in lvm.conf and
> specifying "types").

With those changes LVM2 is supposed to recognize them. Not sure why it
doesn't for you.

> What devices should the LVM scan to use multipathed PVs?

Either the /dev/disk/by-*/ files, or /dev/dm-*; either will do. It's
just important that it only uses those paths and doesn't use the raw
disks (/dev/sdX).

This needs to be addressed to work out-of-the-box later, but for the
time being you'll need to adjust lvm.conf manually.


Sincerely,
    Lars Marowsky-Brée <lmb suse de>

-- 
High Availability & Clustering
SUSE Labs, Research and Development
SUSE LINUX Products GmbH - A Novell Business	 -- Charles Darwin
"Ignorance more frequently begets confidence than does knowledge"


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]