[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] Multipathd not starting up properly



On 30/08/06, Hannes Reinecke <hare suse de> wrote:
Adam Huffman wrote:
> I'm seeing the following messages when I start multipathd:
>
> Aug 29 19:00:21 multipathd: error calling out /sbin/scsi_id -g -u -s
> /block/sda
> Aug 29 19:00:21 multipathd: error calling out /sbin/scsi_id -g -u -s
> /block/sdb
>
> Here is the output of multipath -v 3:
>
>
[ .. ]
> path checker = readsector0 (internal default)
> state = 2
> getprio = (null) (internal default)
> prio = 1
> getuid = /sbin/scsi_id -g -u -s /block/%n (internal default)
> error calling out /sbin/scsi_id -g -u -s /block/sda

This is your problem. Somehow 'scsi_id' cannot talk to the drive.
Try 'sg_inq /dev/sda' to find out where the problem is.


Here's the output of that command:

sg_inq /dev/sda
standard INQUIRY:
 PQual=0  Device_type=0  RMB=0  [ANSI_version=2]  version=0x02
 [AERC=0]  [TrmTsk=0]  NormACA=0  HiSUP=1  Resp_data_format=2
 SCCS=0  ACC=0  ALUA=0  3PC=0  Protect=0
 BQue=0  EncServ=1  MultiP=1  MChngr=0  [ACKREQQ=0]  Addr16=0
 [RelAdr=0]  WBus16=0  Sync=0  Linked=0  [TranDis=0]  CmdQue=1
   length=49 (0x31)   Peripheral device type: disk
Vendor identification: Raidtec
Product identification: JEFF
Product revision level: 0281
Product serial number: 119000020000JEFF

Adam


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]