[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [dm-devel] multipath -l displays nothing



Two problems are very noticeable, pgpolicy should be group_by_prio
instead of failover and the get_prio callout should be set to
/sbin/mpath_prio_emc. 

> -----Original Message-----
> From: dm-devel-bounces redhat com 
> [mailto:dm-devel-bounces redhat com] 
> Sent: Tuesday, March 21, 2006 11:56 AM
> To: dm-devel redhat com
> Subject: [dm-devel] multipath -l displays nothing
> 
> Hello!
> 
> I have a Dell PE1850 with a QLA2342 hooked up to a CX600 with 4
> paths. The Dell is running Debian Sarge with a custom rolled 2.6.16
> kernel. I am using multipath-tools 0.4.7 (compiled from source).
> 
> Simply put, my problem is this:
> 
> laatikko:~# multipath -l
> laatikko:~#
> 
> I'm not going to paste the entire output of multipath -v3 here since
> it is 4504 lines long, but here is a clip of what I suspect might be
> the problem:
> 
> 66:128 ownership set to mpath14
> sdao: not found in pathvec
> sdao: mask = 0xc
> sdao: path checker = emc_clariion (controler setting)
> sdao: state = 2
> sdao: getprio = NULL (internal default)
> sdao: prio = 1
> 68:16 ownership set to mpath14
> sdbn: not found in pathvec
> sdbn: mask = 0xc
> sdbn: path checker = emc_clariion (controler setting)
> sdbn: state = 2
> sdbn: getprio = NULL (internal default)
> sdbn: prio = 1
> 8:80 ownership set to mpath14
> sdf: not found in pathvec
> sdf: mask = 0xc
> sdf: path checker = emc_clariion (controler setting)
> sdf: state = 2
> sdf: getprio = NULL (internal default)
> sdf: prio = 1
> 65:144 ownership set to mpath14
> sdz: not found in pathvec
> sdz: mask = 0xc
> sdz: path checker = emc_clariion (controler setting)
> sdz: state = 2
> sdz: getprio = NULL (internal default)
> sdz: prio = 1
> mpath14: pgfailback = -2 (config file default)
> mpath14: pgpolicy = failover (controler setting)
> mpath14: selector = round-robin 0 (controler setting)
> mpath14: features = 0 (controler setting)
> mpath14: hwhandler = 1 emc (controler setting)
> mpath14: rr_weight = 1 (internal default)
> mpath14: minio = 1000 (config file default)
> mpath14: no_path_retry = NONE (internal default)
> mpath14: set ACT_CREATE (map does not exist)
> mpath14: set ACT_CREATE (map does not exist)
> mpath14: domap (0) failure for create/reload map
>          ^^^^^^^^^^^^
>          This shouldn't happen, right?
> 
> Any ideas on how to fix this?
> 
> -- 
> Jussi Hämäläinen         +358 3 3551 8086   University of Tampere
> System administrator     +358 50  5900641   Computer Centre
> ccjuha uta fi            TietoPinni  4166   
> http://www.uta.fi/laitokset/tkk
> 
> --
> dm-devel mailing list
> dm-devel redhat com
> https://www.redhat.com/mailman/listinfo/dm-devel
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]