[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[dm-devel] Re: lvresize fails with "reload ioctl failed: Invalid argument"



Le 11.09.2006 19:05, Luca Berra a écrit :
On Mon, Sep 11, 2006 at 06:45:57PM +0200, Laurent Riffard wrote:
Le 11.09.2006 16:19, Luca Berra a écrit :
On Sun, Sep 10, 2006 at 11:14:27PM +0100, Alasdair G Kergon wrote:
On Sun, Sep 10, 2006 at 11:38:27PM +0200, Laurent Riffard wrote:
 device-mapper: reload ioctl failed: Invalid argument

 LVM version:     2.02.06 (2006-05-12)
 Library version: 1.02.09 (2006-08-15)
 Driver version:  4.8.0
Linux version 2.6.18-rc6-mm1 (laurent calimero antadix) (gcc version 4.1.1 20060724 (prerelease) (4.1.1-3mdk)) #145 Sun Sep 10 20:48:49 CEST 2006


Is it a known problem ?

Not sure, but try updating lvm2 version to the same date as the
library version (at least 2.02.08 15th August).

Laurent, can you please try the packages from:
http://kenobi.mandriva.com/~bluca/

No luck!

[root calimero ~]# rpm -q lvm2 libdevmapper1.02
lvm2-2.02.09-1mdv2007.0
libdevmapper1.02-1.02.09-1mdv2007.0
[root calimero ~]# lvm2 version
 LVM version:     2.02.09 (2006-08-17)
 Library version: 1.02.09 (2006-08-15)
 Driver version:  4.8.0
[root calimero ~]# lvresize  --extents +1 /dev/vglinux1/lvswap2
 Extending logical volume lvswap2 to 1,00 GB
 device-mapper: reload ioctl failed: Argument invalide
 Failed to suspend lvswap2

Will try vanilla to compile and test vanilla lvm2 2.02.08 as Alasdair suggested.

works for me with 2.6.17-4mdv kernel
maybe something related to your kernel version?

Yes, you seem to be right: it does work with 2.6.17-2mdv or 2.6.17-4mdv, but it fails with 2.6.18-rc6-mm1.

[root calimero ~]# lvm version
 LVM version:     2.02.09 (2006-08-17)
 Library version: 1.02.09 (2006-08-15)
 Driver version:  4.8.0

Maybe, I'll test 2.6.18-rc6 tomorrow.

Thanks for your help.
~~
laurent



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]