[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] Weird discrepancy between /dev/mapper/* and /dev/dm-* devices breaks lilo



On Wed, Jan 31, 2007 at 04:54:29PM +0100, Loïc Minier wrote:
On Wed, Jan 31, 2007, Alasdair G Kergon wrote:
Some distributions chose to configure udev to create /dev/dm-N inodes where
N is the minor number.  (I have always discouraged that as a recipe for
confusion: I believe that using configurable names is a better approach.)

i tend to agree with Alasdair on the above point

I seem to recall even RedHat or Fedora attempted to add these devices,
but I suppose you know best.  The reasons why these were added in udev
in Debian and Ubuntu are mentionned in http://bugs.debian.org/392623,
but in short gnome-mount required this to work; perhaps this should be
fixed in gnome-mount.  The details are in a comment of #401393 though:
 <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=401393;msg=37>

I also looked at the patch to support LUKS into hal and i tought it was
badly written (forgot the gory details)

(attaching the patch I mentionned in the preceding mail but forgot,
sorry)

in any case i lost the argument, so i think that i will use your patch,
at least until grub2 gets support for the eye-candy gfxboot, then i hope
to toss lilo into oblivion.

Thanks for providing the patch,
L.

--
Luca Berra -- bluca comedia it
       Communication Media & Services S.r.l.
/"\
\ /     ASCII RIBBON CAMPAIGN
 X        AGAINST HTML MAIL
/ \


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]