[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[dm-devel] Re: > You may find that you need to update your lvm userspace tools.



On Mon, Feb 04, 2008 at 09:53:04PM -0800, Andrew Morton wrote:
> Could someone in dm-devel land please get involved?

Vague reports like this are sadly a regular occurrence, and they usually
happen when people don't update their initrd after updating their
kernel.  As well as the obvious problems from incompatible modules, some
versions of distros are worse than others, as they foolishly hard-code
device numbers, and a new kernel happens to assign device numbers in a
different sequence breaking everything.  Another cause is when the
distro lets the boot script run too early without waiting for the kernel
to discover all the devices necessary.  Or sometimes kernel/module
changes mean it no longer sees the devices at all.

Alasdair
-- 
agk redhat com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]