[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] RE: Temporarily squelching multipathd errors



On Fri, Jan 16, 2009 at 02:29:40PM -0600, Daniel Keisling wrote:
> Right now I'm deleting the LUN, immediately creating a new LUN, and
> presenting it back to the system with the same SCSI ID.  Since it's a
> snapshot, the LUN geometry is always the same.  I've tried unpresenting
> the LUN, deleting the SCSI devices, recreating/presenting the LUN, and
> then doing a SCSI rescan, but the multipath errors are always there.  
> 
> Here's the multipath listings.  I am only deleting/presenting the
> "mpath33" map, but you can see the multipath errors and the other paths

How are you 'deleting' the mpath33 map? Are you using 'dmsetup remove mpath33'
?

> having a fault:
> 
> Unmounting /dev/mapper/mpath33p1...
> Multipath listing before LUN is deleted...
> cred_arch (3600508b400106fcd0000700011f30000) dm-52 HP,HSV210
> [size=5.0G][features=1 queue_if_no_path][hwhandler=0]

..snip ..
> 
> 
> Multipath listing after LUN is deleted and before LUN is added...

I am not seeing how you are deleting the SCSI device of the node.
Are you doing 'echo 1 > /sys/block/sdab/device/delete' for all
of those block-devices that match the 'deleted LUN'?


.. snip ..
> 
> 
> Multipath output after LUN is added...

How are you doing a SCSI rescan?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]