[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] do Symmetrix multipath-tools defaults need update ? or scsi-to-blk errors management ?



>>
>> ::: error log on a 2.6.9 (rhel 4.7) kernel :::
>>
>
> For RH 4.9 I did the attached patch. So this error is not fastfailed 
> (upstream does not fastfail this type of error when using dm-multipath 
> now). So now the scsi layer will retry its normal 5 times, then fail.
>
Thank you for the information. This is very good news.
Can you also advise about the rhel 5 minimum kernel version ?


>>
>> ::: error log on a 2.6.29.x kernel for a reservation conflict :::
>>
> I was just about to post new blkerr patches. For this we just wan 
> multipath to fail this IO right away right? So have scsi return some 
> fatal error then dm-multipath will see it and not retry that IO?
>
Yes, that would do. Thanks you very much for your prompt response and your work on this.

Regards,
cvaroqui


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]