[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] "multipath -l" not displaying all the paths if we have more than 3000 paths.



On Thu, May 21, 2009 at 11:38:17PM -0700, Harikrishnan Padidakul wrote:
> Hi All
> 
> I downloaded the latest multipath tool from git-clone http://kernel.org/pub/scm/linux/storage/multipath-tools/ <http://kernel.org/pub/scm/linux/storage/multipath-tools/.git> 
> 1) Tested with around 4000 paths(1000LUN exported to four port), and I observed multipath -l is not displaying all the paths.

You have to be more specific here. What kernel are you using?  If you
are using a RHEL5 or SLES10 based there is a race-condition where the
/sys/block devices are created without all the data entries populated
and multipathd can't get all the data from them.

And by
"not displaying all the paths", you mean that it did not have all of the
4 paths per LUN?? Or that you did not have 1000 multipath device maps?

> 2) And when we fail a path by disabling the port, all the path which are failed are not shown in multipath.

Do they show when you do "multipathd -k 'show paths'" as orphans?

Or do they show up if you run 'multipath' by itself?
> 
> Have we tested multipath with more than 3000 paths?
> 
> Thanks in advance.
> 
> Regards,
> Hari

> --
> dm-devel mailing list
> dm-devel redhat com
> https://www.redhat.com/mailman/listinfo/dm-devel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]