[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[dm-devel] Re: Bug on barriers for virtio_blk device - end_request: I/O error, dev vda, sector 0



Added CCs for the author of and people CCed on the patch.

The patch has been submitted twice (6 Aug, 3 Sept), the first time there 
was one concern voiced which seems to have been addressed in replies. The 
second time there were no reactions.

The patch seems to work for Massimo...

Massimo Cetra wrote:
> Massimo Cetra ha scritto:
>> Hello all,
>>
>> i ended up with some thiusands of errors after upgrading to 2.6.31.2
>> like this one:
>>
>> end_request: I/O error, dev vda, sector 0
>> end_request: I/O error, dev vda, sector 0
>> end_request: I/O error, dev vda, sector 0
>> end_request: I/O error, dev vda, sector 0
>>
>> I am using ocfs2 on top of drbd on top of LVM in a KVM guest that uses
>> virtio_blk.
>>
>> The bug is already known, see here:
>> https://bugzilla.redhat.com/show_bug.cgi?id=514901
>>
>> A patch exists and the problem has already been submitted here in the
>> list.
>> See here: http://lkml.org/lkml/2009/8/6/153
>>
>> That fix is not in 2.6.31 nor in 2.6.32-RCX
>>
>> Could you please consider pulling it and adding this fix for inclusion
>> in 2.6.31.$next and also to mainline?
>>
>> Thanks.
>
> No one listening here ?

It helps if you CC the people who maintain the relevant code.

> This makes virtio_blk on LVM unusable.

Cheers,
FJP


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]