[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [dm-devel] multipath: partitions are not created on IBM 1746 (SAS connection to DS3512)



On sam., 2011-02-12 at 12:12 +0300, Peter Volkov wrote:
> Thank you Christophe and Malahal.
> 
> В Срд, 09/02/2011 в 11:22 +0100, Christophe Varoqui пишет:
> > On mer., 2011-02-09 at 13:08 +0300, Peter Volkov wrote:
> > > root btv1:~# cat /etc/multipath.conf 
> > > defaults {
> > > 	path_checker	rdac
> > > }
> > > 
> > the 'path_checker' param does not set the hwhandler.
> > the keyword for that is 'hardware_handler'.
> 
> Is this an error in man multipath.conf then (it mentions rdac in
> path_checker section)?
> 
No, rdac is also a valid valid value for path_checker.

> Anyway I've updated multipath-tools on ubuntu and this fixed initial
> issue, but now I experience different problem with multipath. For
> unknown reasons multipath does not automagically create partitions on
> Gentoo system, although everything works if I run `kpartx -a /dev/dm-0`
> manually. Could you help me to investigate this issue?
> 
You must keep the distribution udev rules. And report bugs to them. Nor
multipath or multipathd care about partitions. Those create multipath
device maps and upon creation udev is responsible for calling kpartx.

Check the multipath-tools 'make install' output to see what it may
unduly install as udev rules.

Regards,
cvaroqui



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]