[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[dm-devel] why doesn't multipathd use the device?



Hello everyone,

We have hit this problem a couple of times now on our RHEL 6.2 initiators using our FC target. We have many dm devices which should have 4 paths to each. Sometimes we see that some of the dm devices do not have the 4 paths. The underlying /dev/sd devices do exist but they are not used by the dm device. Here is what I see:

mpathbbt (3624a9370f9b69331bb3d16650001000b) dm-11 PURE,FlashArray
size=500G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
 |- 1:0:1:12 sds  65:32  active ready running
 `- 1:0:0:12 sdae 65:224 active ready running

However there are devices for the remaining two paths they are just not being used by multipathd:

/dev/sg18  1 0 1 12  0  /dev/sds  PURE      FlashArray        100 
/dev/sg30  1 0 0 12  0  /dev/sdae  PURE      FlashArray        100 
/dev/sg39  0 0 1 12  0  /dev/sdan  PURE      FlashArray        100 
/dev/sg48  0 0 0 12  0  /dev/sdaw  PURE      FlashArray        100

You can see by the LUN serial number that the devices do point to the same LUN on the array. I am including just the LUN serial number, page 0x80, in the interest of space page 0x83's NAA number also matches for the 4 devices:

root r13init31 ~]# sg_inq -p 0x80 /dev/sg18
VPD INQUIRY: Unit serial number page
Unit serial number: F9B69331BB3D16650001000B

[root r13init31 ~]# sg_inq -p 0x80 /dev/sg30
VPD INQUIRY: Unit serial number page
Unit serial number: F9B69331BB3D16650001000B

[root r13init31 ~]# sg_inq -p 0x80 /dev/sg39
VPD INQUIRY: Unit serial number page
Unit serial number: F9B69331BB3D16650001000B

[root r13init31 ~]# sg_inq -p 0x80 /dev/sg48
VPD INQUIRY: Unit serial number page
Unit serial number: F9B69331BB3D16650001000B

I can see in the syslog that there are syslog messages about each of the devices which don't get added to the multipath device like this:
Jun 21 09:23:50 r13init31 kernel: sd 0:0:1:12: [sdan] Attached SCSI disk
Jun 21 09:23:50 r13init31 multipathd: sdan: add path (uevent)
Jun 21 09:23:50 r13init31 multipathd: mpathbbt: failed in domap for addition of new path sdan

My multipath tools version is:
device-mapper-multipath-libs-0.4.9-46.el6_2.2.x86_64
device-mapper-multipath-0.4.9-46.el6_2.2.x86_64

Any ideas why the paths are being rejected by domap?

Thanks,
Brian

Brian Bunker




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]