[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: EPEL-5 and RHEL 5.1 packages



On 08.11.2007 15:52, Richard W.M. Jones wrote:
> I'm trying to build a package (ocaml-libvirt) for EPEL 5.  Unfortunately 
> it depends on libvirt >= 0.2.1.  The version of libvirt on the plague 
> build server seems to be libvirt 0.1.8 (ie. the version which shipped 
> with RHEL 5 GA).  RHEL 5.1 ships with libvirt 0.3.3, so that would be OK.
> 
> Is there anything I can do to build against the newer libvirt?  Or is it 
> just a matter of waiting until the RHEL 5.1 RPMs become available (and 
> if that is the case, what is the likely timeline for that?)

Well, we need to put some thoughts into this -- if we for example start
building packages that require the newer libvirt today then users of
CentOS 5.0 (5.1 is not released yet) and those still on RHEL 5.0.x would
run into dependency issues when using EPEL. We should try hard to avoid
that. That's why I suggested to keep "5.0" directories around for some
weeks months -- but the idea was not that welcomed afaics...

Opinions?

Cu
knurd


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]