[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: EPEL only packages? Review process?



On Mon, Dec 08, 2008 at 02:41:18PM -0800, Ray Van Dolson wrote:
> 
> Would Fedora/RHEL be willing to add an Obsoletes for an EPEL package?
> Were you able to get an Obsoletes included for your package?

In fedora, easily. In RHEL, I still don't know if it is done, but I
filled a bug. (In both case, Jindrich is the maintainer, but it seems
that changing something in RHEL is much more complicated).

> I was just planning to make my package require Python >= 2.3 and <=
> 2.5.  I wonder how this would effect an eventual upgrade from EL5 to
> EL6 when it comes out.

It will lead to a conflict unless something special is going on. 

If your package is for EL-5, then having the obsolete in RHEL6 shouldn't 
be impossible, since if it is in fedora, it should be inherited by RHEL6
package, if it branches from a a fedora package with the obsolete.

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]