[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 5.1 -> 5.2 move



On Mon, Jun 02, 2008 at 02:09:29PM -0400, Bill Nottingham wrote:
> Stephen John Smoogen (smooge gmail com) said: 
> > I don't think we have one. We have dealt with the older policy where
> > things conflicted with 5.1 but not 5.0.
> > 
> > What exactly are the packages having problems?
> 
> gtkhtml3 was rebased in 5.2, changing ABI. We can ship (in EPEL)
> a gtkhtml38 package, but it will conflict at the file level with
> gtkhtml3 from 5.1 and earlier.

The solution could be, in RHEL, to have gtkhtml38 obsolete gtkhtml3
versions with version <= 3.8. It cannot be done in EPEL since obsoleting
RHEL packages is not allowed.

gtkhtml3 would be brought in either by devel dependencies, or by
dependencies on the soname.

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]