[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Broken Deps bugs and fixes for epel 5



On Sat, 20 Sep 2008 17:05:15 -0600, Kevin Fenzi wrote:

> package: libkexiv2 - 0.1.6-3.el5.i386 from epel
>   unresolved deps: 
>      libexiv2.so.0
> 
> Even though I used '-n' to repoclosure, this appears to be due to an
> older version of a exiv2 package still in the repo. 

No.

exiv2-0.17.1-1.el5 from 21-Jul-2008 is ABI-incompatible with previously
published releases of the pkg. It bumps the soname to libexiv2.so.4 (!)

 
> package: thunderbird-lightning-wcap - 0.7-10.el5.i386 from epel
>   unresolved deps: 
>      thunderbird-lightning = 0:0.7
> 
> This is an old package thats been obsoleted (repoclosure doesn't do
> obsoletes I guess). 

Which repoclosure do you use? If you use the one from yum-utils,
you are right. Else it's FUD.


Below find a report for EPEL 5 including "testing" (against CentOS 5)
created on 2008-09-19.

======================================================================
Broken packages in fedora-epel-5-i386:

    libkexiv2-0.1.6-3.el5.i386  requires  libexiv2.so.0


======================================================================
Broken packages in fedora-epel-5-x86_64:

    libkexiv2-0.1.6-3.el5.i386  requires  libexiv2.so.0
    libkexiv2-0.1.6-3.el5.x86_64  requires  libexiv2.so.0()(64bit)


======================================================================
Broken packages in fedora-epel-testing-5-i386:

    abgraph-1.1-1.el5.noarch  requires  httpd-tools
    claws-mail-plugins-dillo-3.3.1-1.el5.i386  requires  dillo
    emacs-gambit-4.2.8-6.el5.i386  requires  emacs(bin) >= 0:21.4
    emacs-vala-0.3.4-2.el5.i386  requires  emacs(bin) >= 0:21.4
    flumotion-0.4.2-2.el5.i386  requires  pycrypto
    gnome-applet-sshmenu-3.15-5.el5.noarch  requires  ruby(panelapplet2)
    gnome-applet-sshmenu-3.15-5.el5.noarch  requires  ruby(gconf2)
    grc-0.70-3.el5.noarch  requires  gnuradio
    hellanzb-0.13-5.el5.noarch  requires  python-twisted
    hellanzb-0.13-5.el5.noarch  requires  par2cmdline
    hunspell-he-1.0-7.el5.i386  requires  hunspell
    mediawiki-ParserFunctions-1.1.1-1.20080520svn35130.el5.noarch  requires  mediawiki >= 0:1.10
    perl-Collectd-4.4.3-1.el5.i386  requires  perl(Config::General)
    perl-libwhisker2-2.4-3.el5.noarch  requires  perl(MD5)
    python-Coherence-0.2.1-3.el5.noarch  requires  python-nevow
    python-peak-rules-0.5a1.dev-0.2569.el5.noarch  requires  python-decoratortools >= 0:1.7
    sshfp-1.1.3-2.el5.noarch  requires  python-dns
    sshmenu-3.15-5.el5.noarch  requires  ruby(gtk2)
    supybot-0.83.3-7.el5.noarch  requires  python-dictclient
    tkimg-1.3-0.8.20080505svn.el5.i386  requires  tcl(abi) = 0:8.4
    translate-toolkit-0.10.1-1.el5.noarch  requires  python-enchant
    vala-tools-0.3.4-2.el5.i386  requires  gnome-common
    viewmtn-0.10-1.el5.noarch  requires  highlight


======================================================================
Broken packages in fedora-epel-testing-5-x86_64:

    abgraph-1.1-1.el5.noarch  requires  httpd-tools
    claws-mail-plugins-dillo-3.3.1-1.el5.x86_64  requires  dillo
    emacs-gambit-4.2.8-6.el5.x86_64  requires  emacs(bin) >= 0:21.4
    emacs-vala-0.3.4-2.el5.x86_64  requires  emacs(bin) >= 0:21.4
    flumotion-0.4.2-2.el5.x86_64  requires  pycrypto
    gnome-applet-sshmenu-3.15-5.el5.noarch  requires  ruby(panelapplet2)
    gnome-applet-sshmenu-3.15-5.el5.noarch  requires  ruby(gconf2)
    grc-0.70-3.el5.noarch  requires  gnuradio
    hellanzb-0.13-5.el5.noarch  requires  python-twisted
    hellanzb-0.13-5.el5.noarch  requires  par2cmdline
    hunspell-he-1.0-7.el5.x86_64  requires  hunspell
    mediawiki-ParserFunctions-1.1.1-1.20080520svn35130.el5.noarch  requires  mediawiki >= 0:1.10
    perl-Collectd-4.4.3-1.el5.x86_64  requires  perl(Config::General)
    perl-libwhisker2-2.4-3.el5.noarch  requires  perl(MD5)
    python-Coherence-0.2.1-3.el5.noarch  requires  python-nevow
    python-peak-rules-0.5a1.dev-0.2569.el5.noarch  requires  python-decoratortools >= 0:1.7
    sshfp-1.1.3-2.el5.noarch  requires  python-dns
    sshmenu-3.15-5.el5.noarch  requires  ruby(gtk2)
    supybot-0.83.3-7.el5.noarch  requires  python-dictclient
    tkimg-1.3-0.8.20080505svn.el5.i386  requires  tcl(abi) = 0:8.4
    tkimg-1.3-0.8.20080505svn.el5.x86_64  requires  tcl(abi) = 0:8.4
    translate-toolkit-0.10.1-1.el5.noarch  requires  python-enchant
    vala-tools-0.3.4-2.el5.x86_64  requires  gnome-common
    viewmtn-0.10-1.el5.noarch  requires  highlight


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]