[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: new perl package needs newer versions of dependancies.



On Mon, Sep 21, 2009 at 02:34:04PM -0700, Christopher wrote:
> + /usr/bin/perl Build.PL installdirs=vendor
>  - ERROR: Test::More (0.62) is installed, but we need version >= 0.78
>  - ERROR: perl (5.008008) is installed, but we need version >= 5.6001
>  - ERROR: Test::Builder (0.32) is installed, but we need version >= 0.78
>  - ERROR: Test::Simple (0.62) is installed, but we need version >= 0.78
> ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the versions
> of the modules indicated above before proceeding with this installation
> Checking whether your kit is complete...
> Looks good
> Checking prerequisites...
> Creating new 'Build' script for 'Test-Class' version '0.31'

I wonder if it really needs perl 5.6?  If so then it seems you're out
of luck.  However, for the Test:: modules: if they are only needed to
run some tests but not for the runtime package, then you could either
not run the tests, or run the tests against a private copy of the
Test::* library which is only used for build and not distributed.

Rich.

-- 
Richard Jones, Emerging Technologies, Red Hat  http://et.redhat.com/~rjones
virt-df lists disk usage of guests without needing to install any
software inside the virtual machine.  Supports Linux and Windows.
http://et.redhat.com/~rjones/virt-df/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]