[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Catalyst in EPEL 6



On Mon, 23 Aug 2010 11:20:59 -0800
"Joshua J. Kugler" <joshua eeinternet com> wrote:

> On Saturday 21 August 2010, Edward Trochim elucidated thus:
> > Hello all,
> >
> > Are there plans to bring the perl Catalyst framework to EPEL 6? The
> > runtime and many of the plugins are already in Fedora 12. I am
> > interested in providing any help that is needed; however, I have
> > never created any packages for either Fedora or EPEL.
> 
> Is there a preference to not simply install it from CPAN?  That would
> be my choice: the packages would stay much more up to date, vs. the
> EPEL update cycle.
> 
> Just wondering.

Personally, I find mixing CPAN installs and installs from rpm to be
very problematic. The issue is that sometimes CPAN will decide to
upgrade something you have installed via rpm (like say, perl itself)
and mess up all other packages installed from rpm. Also, on the other
side, rpm packaged modules may upgrade something you installed from
CPAN and cause breakage there. 

So, my suggestion would be to stick with one and only one package
management system. In my case rpm/yum. :) 

kevin

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]