[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RFC: EOL of mediawiki from EL-4, EL-5, EL-6



On Tue, Dec 14, 2010 at 06:02:03PM -0700, Stephen John Smoogen wrote:
> On Mon, Dec 13, 2010 at 22:38, Ray Van Dolson <rayvd bludgeon org> wrote:
> 
> > I notice a few RPM-packaged extensions are tied to the original
> > mediawiki package -- mediawiki-ParserFunctions for example.
> >
> > Maybe /usr/share/mediawiki would be a good "generic" directory for
> > non-version specific extension?  Or should we get them repackaged per
> > version?
> >
> > For now I'll just install from source most likely.
> 
> This was going to be my next thing to deal with. Some of the mediawiki
> extensions work with the latest and others do not. I am not sure of
> which :). I guess I need to ask the packaging committee on what best
> practice would be
> 

I kind of like the idea of a generic mediawiki extensions directory and
configuring the package to "require" whichever version of MediaWiki it
supports (this requirement could be satisfied by multiple versions).

The package then would either populate the version-specific mediawiki
install's extensions directory with symlinks to the extension or some
other clever trick to ensure it gets made available to the right
versions automatically.

Maybe overengineered?  Seems better than packaging extensions 3+
different times for each mediawiki package...

Ray


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]