[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

bucardo-4.4.0-2.el5 dependency issue on RHEL/Centos 5.X



Looks like there is a dependency issue for bucardo on RHEL/Centos 5.X.  It's failing on postgresql-plperl which doesn't exist in RHN or EPEL repos.  I think the equivalent is postgresql-pl which includes the plperl bit.  Also noticed that you need the rpmforge repo in order to get a perl-DBD-Pg > 2.0.  Just want to verify with people here before submitting a bug report.

[root bobsyouruncle yum.repos.d]# cat /etc/redhat-release
CentOS release 5.4 (Final)

[root pacifica jsaintro]# yum install bucardo
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirror.skiplink.com
 * base: mirror.cogentco.com
 * epel: mirrors.tummy.com
 * extras: mirrors.serveraxis.net
 * rpmforge: apt.sw.be
 * updates: mirror.san.fastserv.com
addons                                                   |  951 B     00:00     
base                                                     | 2.1 kB     00:00     
epel                                                     | 3.4 kB     00:00     
epel/primary_db                                          | 2.4 MB     00:00     
extras                                                   | 2.1 kB     00:00     
rpmforge                                                 | 1.1 kB     00:00     
updates                                                  | 1.9 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package bucardo.noarch 0:4.4.0-2.el5 set to be updated
--> Processing Dependency: perl(DBD::Pg) >= 2.0 for package: bucardo
--> Processing Dependency: postgresql-plperl for package: bucardo
--> Processing Dependency: perl(DBD::Pg) for package: bucardo
--> Processing Dependency: perl(DBIx::Safe) for package: bucardo
--> Running transaction check
---> Package bucardo.noarch 0:4.4.0-2.el5 set to be updated
--> Processing Dependency: postgresql-plperl for package: bucardo
---> Package perl-DBD-Pg.i386 0:2.16.0-1.el5.rf set to be updated
---> Package perl-DBIx-Safe.noarch 0:1.2.5-6.el5 set to be updated
--> Finished Dependency Resolution
bucardo-4.4.0-2.el5.noarch from epel has depsolving problems
  --> Missing Dependency: postgresql-plperl is needed by package bucardo-4.4.0-2.el5.noarch (epel)
Error: Missing Dependency: postgresql-plperl is needed by package bucardo-4.4.0-2.el5.noarch (epel)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]