[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Another puppet 25.4 EL4 issue



It appears the Ruby 1.8.1 version isn't up to the new puppet task:

info: Caching catalog for <snipped node>
/usr/lib64/ruby/1.8/yaml/rubytypes.rb:315: [BUG] Segmentation fault
ruby 1.8.1 (2003-12-25) [x86_64-linux-gnu]

This is http://projects.reductivelabs.com/issues/2604

I updated Ruby 1.8.5 packages ruby, ruby-dev & ruby-libs. After installing those, puppetd works except it has lost the ruby-shadow function:

info: /User[root]: Provider useradd does not support features manages_passwords; not managing attribute password

I tested a few EL4 systems, but didn't have this problem. This system is x86_64, not sure, but I may have tested only 32-bit.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]