[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Supporting Multiple Package Versions (pkg, pkgXY, pkgXZ)



On Tue, 11 May 2010 17:30:46 -0500
BJ Dierkes <wdierkes 5dollarwhitebox org> wrote:

...snip...

> It was my understanding previously that these types of packages would
> be rejected because they 'Conflict with stock RHEL base channel
> packages'.  However I think the policy of not conflicting doesn't
> really apply if a user wants the conflicting package and explicitly
> has to remove the stock package and install a comparable package that
> 'provides' it (postgresql84 Provides: postgresql).

Well, they are not currently something we accept. 

One thing to keep in mind is that Conflicts are nasty to the end user. 
You select things and it downloads it and shows you it's going to
install it and then... wham. Conflict. Sorry, can't do this. This can
be quite anoying if you choose things at install time or have a ks that
happens to pull in conflicting packages. If you conflict you have to
make a system wide decision to use just that newer version, which also
kinda sucks. 

My personal feeling is that we should continue to avoid conflicts in
these packages and require that they be parallel installable with the
base provided version. 

kevin

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]