[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Trac 0.12 in EL5 / EL 6



On 2010-10-14 15:50, Paul Howarth wrote:
> On 14/10/10 15:11, Mirchandani, Dan wrote:
>> The latest version of Trac available for EL5 is 0.10.5 according to
>> http://buildsys.fedoraproject.org/koji/packageinfo?packageID=4008
>>
>> The latest version of Trac available for EL6 is 0.11.7, according to the
>> same link. Any chance of getting Trac 0.11.X (or even Trac 0.12.X) in
>> EL5?
> 
> Highly unlikely. See https://bugzilla.redhat.com/show_bug.cgi?id=605735
> 
> Updates requiring database upgrades are most unlikely to happen in EPEL5.
> An update for EPEL6 is viable (pre RHEL6 GA) if the dependencies are all
> there though.
> 
> Paul.

There may be a blocker problem for EL6 as trac 0.12.x needs
python-genshi 0.6 and this latter package is part of REHL6.

EL6 packages:

 * trac - EPEL6 repo
   http://download.fedora.redhat.com/pub/epel/beta/6/SRPMS/

 * python-genshi - RHEL6 core package
   ftp://ftp.redhat.com/pub/redhat/rhel/beta/5.90Server/source/SRPMS/


The python-genshi update from 0.5.x to 0.6 appears to be pain free
as version 0.6 is compatible with 0.5.x (BZ #626053) (and I have
already update it successfully in my production trac-0.11.7 server).

Note: I also would like to have trac 0.12.x in EPEL6.

Regards,
jpo
-- 
José Pedro Oliveira
* mailto:jpo di uminho pt *


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]