[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Drupal Versioning in EPEL



Hi,

I have packaged a few drupal modules for use on the upcoming fedora
insight. I only noted that drupal 6 in EL is actually called drupal6
when Eric brought it up in the flexinode [1] review.

This is a little messy:

EL-5 and EL-6 now have two separate packages drupal (which is drupal 5)
and drupal6. They are installable in parallel.

Fedora has a Package called drupal which really is drupal 6.

Fedora has a bunch of drupal-modules called drupal-modulename with a
version of 6.x-1.2 (which is what upstream uses to show that this is for
the drupal 6 range).

Eric suggests in the review [1] that I call the package
drupal6-flexinode-1.2 instead of drupal-flexinode-6.x-1.2 - but that
name would only work for EPEL as the other drupal modules which are
already in Fedora are following the 6.x-1.2 naming scheme.

I'm not very experienced wrt. EPEL packaging so I may be missing best
practices here but having a completely separate drupal stack for EPEL
(with two reviews per package ...) feels very wrong to me.

Not sure how feasible it is wrt. the progress of fedora insight but I'd
think that the best way forward would be to leave EL-5 on Drupal 5,
update the drupal package in EL-6 to Drupal 6.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=642856
[2] https://bugzilla.redhat.com/show_bug.cgi?id=569833

-- 
sven === jabber/xmpp: sven lankes net


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]