[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Conflicting Packages Policy (was: python26 note)



On Mon, Oct 18, 2010 at 10:42:08AM -0600, Kevin Fenzi wrote:
> 
> So, some more questions I have: 
> 
> * Would this conflicts case be restricted to just these python26-mod*
>   packages? Or is this more general? I can see the case for packages
>   that use a parallel installable stack and can't load at the same
>   time, but I worry that we should make sure this isn't used more
>   broadly. 
> 
The technical criteria leading to this are:

* Plugins to an app (in this case, mod_{python,wsg} to apache)
* Plugins link to a library that is versioned at the library level but not
  versioned/namespaced at the symbol level.  (In this case, libpython24.so
  and libpython26.so which provide an overlapping set of function names).

Whether to create a general criteria from this or limit it to the specific
case of apache with
mod_python/python26-mod_python/mod_wsgi/python26-mod_wsgi I leave to you :-)

-Toshio

Attachment: pgp2WbBnlUalW.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]