[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

EPEL5 Lua problems (with an update request from 5.1.2-1 to 5.1.4-2+)



Hi,

The current Lua RPMS in EPEL5 [1] are affected by two bugs

 * Bug 495095 - pkg-config reports wrong --libs output for
                lua-devel in EPEL on 64-bit OS
 * Bug 499238 - liblua-5.1.so missing -lm dependency, lua.spec
                fix provided

that make it unsuable. Rebuilding the Fedora lua-5.1.4-4 rpms
for EPEL5 fixed both problems for me.

Could someone please look into it?

tia,
jpo

Additional info
===============================

EPEL Update request
-------------------
Bug 629437 - lua: please update to version-release >= 8.1.4-2


Current bugs that would be fixed
--------------------------------
Bug 495095 - pkg-config reports wrong --libs output for lua-devel in
EPEL on 64-bit OS
Bug 499238 - liblua-5.1.so missing -lm dependency, lua.spec fix provided


Relevant Lua specfile changelog entries
---------------------------------------
...
* Thu Jun 11 2009 Tim Niemueller <tim niemueller de> - 5.1.4-2- Link
liblua.so with -lm (math lib), fixes rhbz #499238
...
* Mon Nov 26 2007 Hans de Goede <j w r degoede hhs nl> 5.1.2-4- Fix
libdir in lua.pc being /usr/lib on x86_64 (bz 399101)
...


Notes:
[1] - Didn't check Lua RPMS in EPEL4
-- 
José Pedro Oliveira
* mailto:jpo di uminho pt *


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]