[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rubygem-rack in epel and fedora



I'd like to bump rubygem-rack to the latest (1.2.1) in Rawhide and
EPEL.  I was worried about EPEL and even started making a seperate
branch for a rack1 package, but according to my queries, the only
packages requiring rack in EPEL are:



EPEL:

stahnma tyr /home/stahnma> repoquery -q --whatrequires "rubygem(rack)"
rubygem-sinatra-1:1.0-2.el5.noarch
rubygem-shotgun-0:0.4-1.el5.noarch



F13:

stahnma olive /home/stahnma> repoquery --whatrequires "rubygem(rack)"
rubygem-actionpack-1:2.3.5-1.fc13.noarch
rubygem-actionpack-1:2.3.5-2.fc13.noarch
rubygem-merb-core-0:1.0.15-1.fc13.noarch
rubygem-shotgun-0:0.4-1.fc13.noarch
rubygem-sinatra-1:0.9.4-2.fc12.noarch
rubygem-sinatra-1:1.0-1.fc13.noarch
rubygem-thin-0:1.2.5-5.fc13.i686


There are some API changes between rack-0.9 and rack-1.2, but mostly
semantics.  For rawhide/fedora, I am pretty sure it will be ok.  What
are the thoughts for this update in EPEL?  It would allow sinatra,
shotgun, and possibly a new (parallel) version of rails.

stahnma


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]