[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora EPEL 5 updates-testing report



The following Fedora EPEL 5 Security updates need testing:

    https://admin.fedoraproject.org/updates/bugzilla-3.2.10-1.el5
    https://admin.fedoraproject.org/updates/drupal7-7.6-1.el5
    https://admin.fedoraproject.org/updates/clamav-0.97.2-3.el5
    https://admin.fedoraproject.org/updates/couchdb-1.0.2-8.el5,erlang-ibrowse-2.2.0-3.el5
    https://admin.fedoraproject.org/updates/cgit-0.9.0.2-2.el5
    https://admin.fedoraproject.org/updates/p7zip-9.20.1-2.el5
    https://admin.fedoraproject.org/updates/rt3-3.6.11-2.el5


The following builds have been pushed to Fedora EPEL 5 updates-testing

    389-admin-1.1.22-1.el5
    389-ds-base-1.2.9.6-1.el5
    fpaste-server-0.2-1.el5
    perl-Test-DistManifest-1.011-4.el5
    perl-Test-HasVersion-0.012-3.el5
    python-fedora-0.3.24-3.el5
    torque-2.5.7-1.el5.1

Details about builds:


================================================================================
 389-admin-1.1.22-1.el5 (FEDORA-EPEL-2011-4076)
 389 Administration Server (admin)
--------------------------------------------------------------------------------
Update Information:

Bug 724808 - startup CGIs write temp file to /
add man pages for ds_removal and ds_unregister
fixes for the makeUpgradeTar.sh script
bugfix
several tls/ssl and migration bug fixes
look for separate openldap ldif library
skip rebranding current brand - add support for different skins
--------------------------------------------------------------------------------
ChangeLog:

* Thu Aug 11 2011 Rich Megginson <rmeggins redhat com> - 1.1.22-1
- Bug 724808 - startup CGIs write temp file to /
- add man pages for ds_removal and ds_unregister
- fixes for the makeUpgradeTar.sh script
* Tue Aug  2 2011 Rich Megginson <rmeggins redhat com> - 1.1.21-1
- Bug 476925 - Admin Server: Do not allow 8-bit passwords for the admin user
* Tue Jul  5 2011 Rich Megginson <rmeggins redhat com> - 1.1.20-1
- Bug 719056 - migrate-ds-admin.pl needs to update SELinux policy
- Bug 718285 - AdminServer should use "service" command instead of start/stop/restart scripts
- Bug 718079 - Perl errors when running migrate-ds-admin.pl
- Bug 713000 - Migration stops if old admin server cannot be stopped
- added tests for the security cgi
- fix typo in NSS_Shutdown warning message
- better NSS error handling - reduce memory leaks
- Bug 710372 - Not able to open the Manage Certificate from DS-console
* Tue Jun 28 2011 Rich Megginson <rmeggins redhat com> - 1.1.19-1
- look for separate openldap ldif library
* Tue Jun 21 2011 Rich Megginson <rmeggins redhat com> - 1.1.18-1
- skip rebranding current brand
- support for skins
* Fri May 13 2011 Rich Megginson <rmeggins redhat com> - 1.1.17-1
- 1.1.17
- support "in-place" upgrade and rebranding from Red Hat to 389
- many fixes for coverity issues
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #724808 - startup CGIs write temp file to /
        https://bugzilla.redhat.com/show_bug.cgi?id=724808
  [ 2 ] Bug #476925 - Admin Server: Do not allow 8-bit passwords for the admin user
        https://bugzilla.redhat.com/show_bug.cgi?id=476925
  [ 3 ] Bug #719056 - migrate-ds-admin.pl needs to update SELinux policy
        https://bugzilla.redhat.com/show_bug.cgi?id=719056
  [ 4 ] Bug #718285 - AdminServer should use "service" command instead of start/stop/restart scripts
        https://bugzilla.redhat.com/show_bug.cgi?id=718285
  [ 5 ] Bug #718079 - Perl errors when running migrate-ds-admin.pl
        https://bugzilla.redhat.com/show_bug.cgi?id=718079
  [ 6 ] Bug #713000 - Migration stops if old admin server cannot be stopped
        https://bugzilla.redhat.com/show_bug.cgi?id=713000
  [ 7 ] Bug #710372 - Not able to open the Manage Certificate from DS-console
        https://bugzilla.redhat.com/show_bug.cgi?id=710372
--------------------------------------------------------------------------------


================================================================================
 389-ds-base-1.2.9.6-1.el5 (FEDORA-EPEL-2011-4080)
 389 Directory Server (base)
--------------------------------------------------------------------------------
Update Information:

Fixes for update, winsync, ruv/counters
Fix another coverity NULL deref in previous patch
Fix coverity NULL deref defect in 1.2.9.3
A few bug fixes
The 1.2.9.0 release - several bug fixes found during alpha testing
389-ds-base-1.2.9.a2 - several bug fixes - automember improvements
look for separate openldap ldif library
Split automember regex rules into separate entries
writing Inf file shows SchemaFile = ARRAY(0xhexnum)
add support for ldif files with changetype: add
Auto Membership
More Coverity fixes
--------------------------------------------------------------------------------
ChangeLog:

* Wed Aug 10 2011 Rich Megginson <rmeggins redhat com> - 1.2.9.6-1
- Bug 728510 - Run dirsync after sending updates to AD
- Bug 729717 - Fatal error messages when syncing deletes from AD
- Bug 729369 - upgrade DB to upgrade from entrydn to entryrdn format is not working.
- Bug 729378 - delete user subtree container in AD + modify password in DS == DS crash
- Bug 723937 - Slapi_Counter API broken on  32-bit F15
-   fixed again - separate tests for atomic ops and atomic bool cas
* Mon Aug  8 2011 Rich Megginson <rmeggins redhat com> - 1.2.9.5-1
- Bug 727511 - ldclt SSL search requests are failing with "illegal error number -1" error
-  Fix another coverity NULL deref in previous patch
* Thu Aug  4 2011 Rich Megginson <rmeggins redhat com> - 1.2.9.4-1
- Bug 727511 - ldclt SSL search requests are failing with "illegal error number -1" error
-  Fix coverity NULL deref in previous patch
* Wed Aug  3 2011 Rich Megginson <rmeggins redhat com> - 1.2.9.3-1
- Bug 727511 - ldclt SSL search requests are failing with "illegal error number -1" error
-  previous patch broke build on el5
* Wed Aug  3 2011 Rich Megginson <rmeggins redhat com> - 1.2.9.2-1
- Bug 727511 - ldclt SSL search requests are failing with "illegal error number -1" error
* Tue Aug  2 2011 Rich Megginson <rmeggins redhat com> - 1.2.9.1-2
- Bug 723937 - Slapi_Counter API broken on  32-bit F15
-   fixed to use configure test for GCC provided 64-bit atomic functions
* Wed Jul 27 2011 Rich Megginson <rmeggins redhat com> - 1.2.9.1-1
- Bug 663752 - Cert renewal for attrcrypt and encchangelog
-   this was "re-fixed" due to a deadlock condition with cl2ldif task cancel
- Bug 725953 - Winsync: DS entries fail to sync to AD, if the User's CN entry contains a comma
- Bug 725743 - Make memberOf use PRMonitor for it's operation lock
- Bug 725542 - Instance upgrade fails when upgrading 389-ds-base package
- Bug 723937 - Slapi_Counter API broken on  32-bit F15
* Fri Jul 15 2011 Rich Megginson <rmeggins redhat com> - 1.2.9.0-1
- Bug 720059 - RDN with % can cause crashes or missing entries
- Bug 709468 - RSA Authentication Server timeouts when using simple paged results on RHDS 8.2.
- Bug 691313 - Need TLS/SSL error messages in repl status and errors log
- Bug 712855 - Directory Server 8.2 logs "Netscape Portable Runtime error -5961 (TCP connection reset by peer.)" to error log whereas Directory Server 8.1 did not
- Bug 713209 - Update sudo schema
- Bug 719069 - clean up compiler warnings in 389-ds-base 1.2.9
- Bug 718303 - Intensive updates on masters could break the consumer's cache
- Bug 711679 - unresponsive LDAP service when deleting vlv on replica
* Mon Jun 27 2011 Rich Megginson <rmeggins redhat com> - 1.2.9-0.2.a2
- 389-ds-base-1.2.9.a2
- look for separate openldap ldif library
- Split automember regex rules into separate entries
- writing Inf file shows SchemaFile = ARRAY(0xhexnum)
- add support for ldif files with changetype: add
- Bug 716980 - winsync uses old AD entry if new one not found
- Bug 697694 - rhds82 - incr update state stop_fatal_error "requires administrator action", with extop_result: 9
- bump console version to 1.2.6
- Bug 711679 - unresponsive LDAP service when deleting vlv on replica
- Bug 703703 - setup-ds-admin.pl asks for legal agreement to a non-existant file
- Bug 706209 - LEGAL: RHEL6.1 License issue for 389-ds-base package
- Bug 663752 - Cert renewal for attrcrypt and encchangelog
- Bug 706179 - DS can not restart after create a new objectClass has entryusn attribute
- Bug 711906 - ns-slapd segfaults using suffix referrals
- Bug 707384 - only allow FIPS approved cipher suites in FIPS mode
- Bug 710377 - Import with chain-on-update crashes ns-slapd
- Bug 709826 - Memory leak: when extra referrals configured
* Thu May 26 2011 Rich Megginson <rmeggins redhat com> - 1.2.9-0.1.a1
- 389-ds-base-1.2.9.a1
- Auto Membership
- More Coverity fixes
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #728510 - WinSync: Renaming an user(which is synced from DS to AD) at AD is creating a new user at DS.
        https://bugzilla.redhat.com/show_bug.cgi?id=728510
  [ 2 ] Bug #729717 - Windows sync logs errors when a delete is synced from AD
        https://bugzilla.redhat.com/show_bug.cgi?id=729717
--------------------------------------------------------------------------------


================================================================================
 fpaste-server-0.2-1.el5 (FEDORA-EPEL-2011-4077)
 Fedora Pastebin
--------------------------------------------------------------------------------
Update Information:

Minor code fixes, setup.py improvements and some adjustments to the spec
--------------------------------------------------------------------------------
ChangeLog:

* Wed Aug 10 2011 Clint Savage <herlo fedoraproject org> 0.2-1
- Cleaned up pathing and config files
--------------------------------------------------------------------------------


================================================================================
 perl-Test-DistManifest-1.011-4.el5 (FEDORA-EPEL-2011-4089)
 Author test that validates a package MANIFEST
--------------------------------------------------------------------------------
Update Information:

This is the first EPEL release of perl-Test-DistManifest.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #672543 - Review Request: perl-Test-DistManifest - Author test that validates a package MANIFEST
        https://bugzilla.redhat.com/show_bug.cgi?id=672543
--------------------------------------------------------------------------------


================================================================================
 perl-Test-HasVersion-0.012-3.el5 (FEDORA-EPEL-2011-4094)
 Check Perl modules have version numbers
--------------------------------------------------------------------------------
Update Information:

This is the first EPEL release of perl-Test-HasVersion.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #693037 - Review Request: perl-Test-HasVersion - Check Perl modules have version numbers
        https://bugzilla.redhat.com/show_bug.cgi?id=693037
--------------------------------------------------------------------------------


================================================================================
 python-fedora-0.3.24-3.el5 (FEDORA-EPEL-2011-4086)
 Python modules for talking to Fedora Infrastructure Services
--------------------------------------------------------------------------------
Update Information:

* Update splits off server packages and sets proper dependencies on web application frameworks in those subpackages.
* Fix a bug with auth for TG2 servers
* Fix a bug in client auth using F15+ pycurl
* Fix a bug with auth for TG2 servers
* Fix a bug in client auth using F15+ pycurl
--------------------------------------------------------------------------------
ChangeLog:

* Tue Aug  9 2011 Toshio Kuratomi <toshio fedoraproject org> - 0.3.24-3
- Get the PYTHONPATH for building docs correct
* Tue Aug  9 2011 Toshio Kuratomi <toshio fedoraproject org> - 0.3.24-2
- Rework package to provide the turbogears and django code in subpackages with
  full dependencies for each of those.
* Wed Jul 20 2011 Toshio Kuratomi <toshio fedoraproject org> - 0.3.24-1
- Upstream 0.3.24 release bugfixing TG2 server utils and clients with
  session cookie auth.
--------------------------------------------------------------------------------


================================================================================
 torque-2.5.7-1.el5.1 (FEDORA-EPEL-2011-3933)
 Tera-scale Open-source Resource and QUEue manager
--------------------------------------------------------------------------------
Update Information:

**Warning: Significant change, munge enabled - action required:**

The updated EPEL5 build of torque-2.5.7-1 as compared to previous versions enables munge[1] as an inter node authentication method.

It is highly advisable that prior to upgrading to version 2.5.7-1 of this torque package that munge is installed and enabled. A munge package[2] is of course available within EPEL5.

 * [1] http://code.google.com/p/munge/
 * [2] https://admin.fedoraproject.org/community/?package=munge#package_maintenance

To enable munge on your torque cluster:

 * Install the munge package everywhere on your cluster.
 * On one host generate a key with */usr/sbin/create-munge-key*
 * Copy the key, /etc/munge/munge.key to all hosts on your cluster.
 * Start the munge deamon everywhere. **service munge start && chkconfig munge on**

**Warning: New internal format for Job arrays:**

TORQUE 2.5 uses a new format for job arrays. It in not backwards
compatible with job arrays from version 2.3 or 2.4. Therefore, it is imperative that the system be drained of any job arrays BEFORE upgrading. Upgrading with job arrays queued or running may cause data loss, crashes, etc, and is not supported.

This update  from 2.3.10 includes numerous bugfixes and enhancements. Please read the torque ChangeLog.The significant changes that require action prior to upgrade are however detailed above.



--------------------------------------------------------------------------------
ChangeLog:

* Wed Aug 10 2011 Steve Traylen <steve traylen cern ch> - 2.5.7-1 1
- Don't include nodes file rhbz#716659
* Tue Jul 26 2011 Steve Traylen <steve traylen cern ch> - 2.5.7-1
- Big update to 2.5.7-1, drop torque-buffer-overrun-2.3.13.patch,
  change license from OpenPBS to OpenPBS and TORQUEv1.1
- Enabled or rather force munge support.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #716659 - Torque updates Overwrite nodes file
        https://bugzilla.redhat.com/show_bug.cgi?id=716659
--------------------------------------------------------------------------------



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]