[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora EPEL 4 updates-testing report



The following Fedora EPEL 4 Security updates need testing:

    https://admin.fedoraproject.org/updates/torque-2.5.7-1.el4.1


The following builds have been pushed to Fedora EPEL 4 updates-testing

    spamass-milter-0.3.2-3.el4

Details about builds:


================================================================================
 spamass-milter-0.3.2-3.el4 (FEDORA-EPEL-2011-4252)
 Milter (mail filter) for spamassassin
--------------------------------------------------------------------------------
Update Information:

This change is to help systems with Postfix handle mail from authenticated users better.

Postfix doesn't support Sendmail's {auth_ssf} macro and this was causing the milter not to give any indication to SpamAssassin that mail from an authenticated user was trusted; the update enhances the milter to use the {auth_authen} macro (supported by both Postfix and Sendmail) to identify authenticated users to SpamAssassin, which then treats the mail as being from a trusted source. Of course the -I option (off by default) can still be used to get the milter to accept mail from authenticated users straight away without passing it through SpamAssassin if preferred.

The update also drops the wrapper script that restarts the milter if it crashes; the wrapper hasn't been necessary since version 0.3.1 when its reliability improved significantly.

Finally, this update adds support for whitelisting of IPv6 networks in addition to the existing support for IPv4 networks.
--------------------------------------------------------------------------------
ChangeLog:

* Thu Aug 18 2011 Paul Howarth <paul city-fan org> 0.3.2-3
- Help for users authenticating to Postfix (#730308)
* Mon Jul 18 2011 Paul Howarth <paul city-fan org> 0.3.2-2
- Drop the wrapper, which hasn't been needed since 0.3.1 was released
- Nobody else likes macros for commands
* Tue Feb 15 2011 Paul Howarth <paul city-fan org> 0.3.2-1
- Update to 0.3.2 (upstream fix for popen unsanitized input vulnerability:
  CVE-2010-1132, #572117, #572119, http://savannah.nongnu.org/bugs/?29136)
- Drop popen patch, now upstream
- Rework syntax, rcvd and bits patches to apply against new codebase
* Tue Nov 30 2010 Paul Howarth <paul city-fan org> 0.3.1-24
- Require systemd-units for ownership of /etc/tmpfiles.d directory
- Add Default-Stop LSB keyword in initscript
* Fri Nov 26 2010 Paul Howarth <paul city-fan org> 0.3.1-23
- Make sure /var/run/spamass-milter and /var/run/spamass-milter/postfix exist
  at boot time for systems with /var/run on tmpfs (#656692)
* Thu Sep 23 2010 Paul Howarth <paul city-fan org> 0.3.1-21
- Add IPv6 whitelisting support (#630263)
* Tue Jun  8 2010 Paul Howarth <paul city-fan org> 0.3.1-20
- RHEL-6 onwards have noarch subpackages, so make spamass-milter-postfix one
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #730308 - spamass-milter does not detect Postfix authenticated mail
        https://bugzilla.redhat.com/show_bug.cgi?id=730308
--------------------------------------------------------------------------------



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]