[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora EPEL 5 updates-testing report



The following Fedora EPEL 5 Security updates need testing:

    https://admin.fedoraproject.org/updates/libsndfile-1.0.17-4.el5
    https://admin.fedoraproject.org/updates/wordpress-2.8.6-3.el5
    https://admin.fedoraproject.org/updates/wordpress-mu-2.9.2-2.el5
    https://admin.fedoraproject.org/updates/perl-Convert-UUlib-1.34-1.el5
    https://admin.fedoraproject.org/updates/Django-1.1.3-1.el5
    https://admin.fedoraproject.org/updates/perl-CGI-Simple-1.112-2.el5


The following builds have been pushed to Fedora EPEL 5 updates-testing

    cmake-fedora-0.4.0-1.el5
    etckeeper-0.51-1.el5
    fedora-packager-0.5.2.0-2.el5
    netstat-nat-1.4.10-1.el5
    perl-Package-Stash-XS-0.19-1.el5

Details about builds:


================================================================================
 cmake-fedora-0.4.0-1.el5 (FEDORA-EPEL-2011-0038)
 CMake helper modules for fedora developers
--------------------------------------------------------------------------------
Update Information:

- New target: release
- New target: install_rpms
- ./Module should precedes /usr/share/cmake/Modules, so
it always use latest modules.
- Fixed Reading a file that contains '\'.
- Added Macro PACK_RPM_GET_ARCH
- Added target install_rpms for bulk rpms installation.
- Target rpm now uses -bb instead of -ba.
- Target rpm now depends on srpm.
- Source version control logic is split out as ManageSourceVersionControl
- Module UseHostingService is renamed as ManageMaintainerTarget
- Macro USE_HOSTING_SERVICE_READ_SETTING_FILE is renamed as
MAINTAINER_SETTING_READ_FILE
- Fixed: Support for out-of-source build.
- Fixed: Join the next line if ended with back slash '\'.
- ChangeLog: Now generate from "cmake ." directly.
- changelog: target removed. So it won't do unnecessary rebuild.
--------------------------------------------------------------------------------
ChangeLog:

* Fri Jan  7 2011 Ding-Yi Chen <dchen at redhat.com> - 0.4.0-1
- New target: release
- New target: install_rpms
- ./Module should precedes /usr/share/cmake/Modules, so
  it always use latest modules.
- Fixed Reading a file that contains '\'.
- Added Macro PACK_RPM_GET_ARCH
- Added target install_rpms for bulk rpms installation.
- Target rpm now uses -bb instead of -ba.
- Target rpm now depends on srpm.
- Source version control logic is split out as ManageSourceVersionControl
- Module UseHostingService is renamed as ManageMaintainerTarget
- Macro USE_HOSTING_SERVICE_READ_SETTING_FILE is renamed as
  MAINTAINER_SETTING_READ_FILE
* Sun Dec 19 2010 Ding-Yi Chen <dchen at redhat.com> - 0.3.3-1
- Fixed: Support for out-of-source build.
- Fixed: Join the next line if ended with back slash '\'.
- ChangeLog: Now generate from "cmake ." directly.
- changelog: target removed. So it won't do unnecessary rebuild.
--------------------------------------------------------------------------------


================================================================================
 etckeeper-0.51-1.el5 (FEDORA-EPEL-2011-0036)
 Store /etc in a SCM system (git, mercurial, bzr or darcs)
--------------------------------------------------------------------------------
Update Information:

Update etckeeper to version 0.51, with these and other changes:

 * Improve rpm version change detection.
 * Move etckeeper out of sbin, to avoid needing to work around broken root PATH settings in eg, crontab.

Complete list of changes (including Debian bug numbers) can be found here: http://joey.kitenet.net/code/etckeeper/news/version_0.51/
--------------------------------------------------------------------------------
ChangeLog:

* Mon Jan  3 2011 Thomas Moschny <thomas moschny gmx de> - 0.51-1
- Update to 0.51.
- etckeeper has been moved out of sbin.
* Sat Dec 11 2010 Thomas Moschny <thomas moschny gmx de> - 0.50-2
- Don't package INSTALL.
--------------------------------------------------------------------------------


================================================================================
 fedora-packager-0.5.2.0-2.el5 (FEDORA-EPEL-2011-0037)
 Tools for setting up a fedora maintainer environment
--------------------------------------------------------------------------------
Update Information:

update to upstream 0.5.2.0 read ChangeLog for full details
--------------------------------------------------------------------------------
ChangeLog:

* Thu Jan  6 2011 Dennis Gilmore <dennis ausil us> - 0.5.2.0-2
- move python-offtrac requires to fedpkg from fedora-packager
* Wed Jan  5 2011 Dennis Gilmore <dennis ausil us> - 0.5.2.0-1
- update to new upstream release read changeLog for changes
- drop upstream patches
* Mon Oct 18 2010 Dan Horák <dan[at]danny.cz> - 0.5.1.4-7
- revert the last change as %ifarch doesn't work with noarch packages
  and I also got ykpers built on s390(x)
* Mon Oct 18 2010 Dan Horák <dan[at]danny.cz> - 0.5.1.4-6
- don't Require ykpers and don't install fedora-burn-yubikey on s390(x)
* Sun Oct 10 2010 Dennis Gilmore <dennis ausil us> - 0.5.1.4-5
- fedpkg needs python-fedora
* Sun Oct 10 2010 Dennis Gilmore <dennis ausil us> - 0.5.1.4-4
- fedpkg needs koji installed
- fedora-cert needs pycurl when installed by itself
* Sun Oct 10 2010 Dennis Gilmore <dennis ausil us> - 0.5.1.4-3
- move Requires: python-pycurl to fedpkg
* Sun Oct 10 2010 Dennis Gilmore <dennis ausil us> - 0.5.1.4-2
- split out fedora-cert tool and library
- add fedora-burn-yubikey tool
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #627174 - fedpkg co -B <package> dysfunctional
        https://bugzilla.redhat.com/show_bug.cgi?id=627174
  [ 2 ] Bug #628504 - [abrt] fedpkg-0.5.1.2-2.fc13: fedpkg:120:display_state:TypeError: 'NoneType' object is unsubscriptable
        https://bugzilla.redhat.com/show_bug.cgi?id=628504
  [ 3 ] Bug #632097 - [abrt] fedpkg-0.5.1.4-1.fc13: __init__.py:193:_run_command:UnboundLocalError: local variable 'proc' referenced before assignment
        https://bugzilla.redhat.com/show_bug.cgi?id=632097
  [ 4 ] Bug #632702 - fedpkg bash completion broken
        https://bugzilla.redhat.com/show_bug.cgi?id=632702
  [ 5 ] Bug #634888 - fedpkg local returns zero exit code even on failure
        https://bugzilla.redhat.com/show_bug.cgi?id=634888
  [ 6 ] Bug #634946 - [abrt] fedpkg-0.5.1.4-1.fc13: __init__.py:1718:_callMethod:AuthError: Invalid session or bad credentials
        https://bugzilla.redhat.com/show_bug.cgi?id=634946
  [ 7 ] Bug #655576 - [abrt] fedpkg-0.5.1.4-5.fc14: __init__.py:1210:gimmespec:FedpkgError: No spec file found.
        https://bugzilla.redhat.com/show_bug.cgi?id=655576
  [ 8 ] Bug #656897 - [abrt] fedpkg-0.5.1.4-5.fc14: __init__.py:619:sources:IOError: [Errno 2] No such file or directory: '/home/yarda/git-fedora/rrdtool/master/rrdtool-1.4.4/sources'
        https://bugzilla.redhat.com/show_bug.cgi?id=656897
  [ 9 ] Bug #667433 - fedpkg aborts with AttributeError
        https://bugzilla.redhat.com/show_bug.cgi?id=667433
--------------------------------------------------------------------------------


================================================================================
 netstat-nat-1.4.10-1.el5 (FEDORA-EPEL-2011-0035)
 A tool that displays NAT connections
--------------------------------------------------------------------------------
Update Information:

netstat-nat 1.4.10

- fix for properly display DNAT over SNAT connection
--------------------------------------------------------------------------------
ChangeLog:

* Fri Jan  7 2011 Alexey Kurov <nucleo fedoraproject org> - 1.4.10-1
- netstat-nat 1.4.10
- fix for properly display DNAT over SNAT connection
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng lists fedoraproject org> - 1.4.9-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
--------------------------------------------------------------------------------


================================================================================
 perl-Package-Stash-XS-0.19-1.el5 (FEDORA-EPEL-2011-0039)
 Faster and more correct implementation of the Package::Stash API
--------------------------------------------------------------------------------
Update Information:

This update provides a more correct validity test for scalars, and is needed for a forthcoming update to the current Package::Stash module.
--------------------------------------------------------------------------------
ChangeLog:

* Thu Jan  6 2011 Paul Howarth <paul city-fan org> - 0.19-1
- Update to 0.19 (more correct validity test for scalars)
- Update patch for old Test::More versions
--------------------------------------------------------------------------------



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]