[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: epel beta report: 20110110 changes



On Tue, 11 Jan 2011 15:47:22 +0100
Michael Schwendt <mschwendt gmail com> wrote:

> On Tue, 11 Jan 2011 15:32:25 +0100, Dan wrote:
> 
> > EPEL Beta Report píše v Po 10. 01. 2011 v 18:15 +0000: 
> > > Compose started at Mon Jan 10 17:37:27 UTC 2011
> > > 
> > > Broken deps for x86_64
> > > ----------------------------------------------------------
> > > 	1:java-1.6.0-openjdk-plugin-1.6.0.0-1.21.b17.el6.x86_64
> > > requires java-1.6.0-openjdk = 1:1.6.0.0-1.21.b17.el6
> > 
> > does anybody know what's broken here?
> 
> Just from the looks of it, is java-1.6.0-openjdk-plugin obsolete but
> missing a proper "Obsoletes" tag? What package EVRs do you see if you
> run some queries?

We dug into this as the request of the java-1.6.0-openjdk folks, who
are getting a broken dep report about it. :) 

- The plugin was shipped in beta2, but they decided they didn't want to
  support it in 6.0, so it was supposed to be removed. 

- They added obsoletes, but not provides to the main java-1.6.0-openjdk
  package. 

- They failed to remove the old plugin package from rhn channels with
  6.0. It's in the optional channel. ;( 

So, nothing epel can do here. They either need to fix the
java-1.6.0-openjdk package or (better imho), just stop shipping the old
plugin that could never be installed or work. ;) 

kevin

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]