[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora EPEL 5 updates-testing report



The following Fedora EPEL 5 Security updates need testing:

    https://admin.fedoraproject.org/updates/wordpress-2.8.6-4.el5
    https://admin.fedoraproject.org/updates/wordpress-mu-2.9.2-3.el5
    https://admin.fedoraproject.org/updates/perl-Convert-UUlib-1.34-1.el5
    https://admin.fedoraproject.org/updates/Django-1.1.3-1.el5
    https://admin.fedoraproject.org/updates/perl-CGI-Simple-1.112-2.el5


The following builds have been pushed to Fedora EPEL 5 updates-testing

    blender-2.49b-9.el5
    freealut-1.1.0-11.el6
    holland-1.0.6-2.el5
    libzdb-2.7-1.el5
    libzdb-2.7-1.el6
    perl-Getopt-GUI-Long-0.91-5.el5
    python-jsonpickle-0.3.1-2.1.el5
    root-5.28.00-1.el5.1

Details about builds:


================================================================================
 blender-2.49b-9.el5 (FEDORA-EPEL-2011-0069)
 3D modeling, animation, rendering and post-production
--------------------------------------------------------------------------------
Update Information:

Fix a dependency issue agains gettext in RHEL 5.6
--------------------------------------------------------------------------------
ChangeLog:

* Sat Jan 15 2011 Jochen Schmitt <Jochen herr-schmitt de> - 2.49b-9
- Rebuild to fix broken dependency to gettext (#669843)
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #669843 - Blender package broken dependency with RHEL 5.6
        https://bugzilla.redhat.com/show_bug.cgi?id=669843
--------------------------------------------------------------------------------


================================================================================
 freealut-1.1.0-11.el6 (FEDORA-EPEL-2011-0073)
 Implementation of OpenAL's ALUT standard
--------------------------------------------------------------------------------
Update Information:

Add missing freealut package into EPEL-6
--------------------------------------------------------------------------------
ChangeLog:

* Sat Nov  7 2009 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.1.0-11
- require openal-soft in devel (#533599)
* Tue Aug 11 2009 Jochen Schmitt <Jochen herr-schmitt de> 1.1.0-10
- Build agains openal-soft
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng lists fedoraproject org> - 1.1.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Mar 18 2009 Robert Scheck <robert fedoraproject org> - 1.1.0-8
- Rebuilt against libtool 2.2 to avoid libtool errors
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng lists fedoraproject org> - 1.1.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng fedoraproject org> - 1.1.0-6
- Autorebuild for GCC 4.3
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #533599 - freealut bad dependency
        https://bugzilla.redhat.com/show_bug.cgi?id=533599
--------------------------------------------------------------------------------


================================================================================
 holland-1.0.6-2.el5 (FEDORA-EPEL-2011-0071)
 Pluggable Backup Framework
--------------------------------------------------------------------------------
ChangeLog:

* Thu Jan 13 2011 BJ Dierkes <wdierkes rackspace com> - 1.0.6-2
- Remove Requires: xtrabackup from holland-xtrabackup.  Fedora
  doesn't provide xtrabackup currently, however there are solutions
  out there that people may want to use holland-xtrabackup for.
* Wed Jan 12 2011 BJ Dierkes <wdierkes rackspace com> - 1.0.6-1
- Latest sources from upstream.  Full change log available at:
  http://hollandbackup.org/releases/stable/1.0/CHANGES.txt
- ChangeLog became CHANGES.txt
- Add pgdump and xtrabackup by default
- No longer package -random by default (shouldn't have been in
  anyway).  Main package Obsoletes: holland-random < 1.0.6
* Tue Dec 14 2010 BJ Dierkes <wdierkes rackspace com> - 1.0.5-1
- Development version
* Tue Dec 14 2010 BJ Dierkes <wdierkes rackspace com> - 1.0.4-3
- Remove condition check around setting python_site{lib,arch} as
  it is not supported in el4.
- No longer set python_sitearch as we aren't using it
--------------------------------------------------------------------------------


================================================================================
 libzdb-2.7-1.el5 (FEDORA-EPEL-2011-0075)
 Small, fast, and easy to use database API
--------------------------------------------------------------------------------
Update Information:

This is a feature and bug fix release which has been tested on the following platforms:

 * Linux 2.6 (x86 and x64)
 * Mac OS X Snow Leopard (Darwin 10.6.x i386/x86_64)
 * Mac OS X Leopard (Darwin 10.5.x ppc)
 * FreeBSD 6.x, 7.x and 8.x (x86 and x64)
 * Solaris 10 and Solaris Express (sparc and x86)
 * OpenBSD 4.x (x86 and x64)


Release notes:
--------------

This release brings tentative Oracle support to libzdb thanks to Volodymyr Tarasenko. If you already have Oracle installed on your system, then simply running configure should pick it up. Otherwise if you want to build libzdb with Oracle support, but don't have Oracle installed (like me) it is a bit more work. Here's what I did; download Instant Client (basic and sdk) from http://www.oracle.com/ Create a oci directory someplace and copy header files and libs into this directory. Then use this configure statement; ./configure --with-oci-include=/<path>/oci/include --with-oci-lib=/<path>/oci/lib 

The Oracle implementation is not quite yet production ready which emerge from the change log below, though for most practical purposes it should work - according to Volodymyr. If you want to help out testing and improving it, please do.

The SQLite implementation has been further improved by adding a configure option to make SQLite release unused memory. This is very useful as SQLite does not care so much about releasing memory and its memory usage can grow considerably if left unchecked. 



Changes in this release:
------------------------

* Added tentative support for Oracle. Thanks to Volodymyr
  Tarasenko, and Sergey Pavlov for implementing this.
  This implementation does not support BLOB, though CLOB
  is supported. It will also not run all zdb unit tests,
  but should be useful for most purposes. It is released
  with the hope that others may still find it useful and
  help iron out any remaining issues.

* Added new convenience zdb.h meta include file which
  can be used to include all required API interfaces

* Internal optimizing changes and improvements - we simply
  adore refactoring

* SQLite: Clear connection on rollback to prevent SQLite
  from issue an SQLITE_BUSY error if there are pending
  selects in progress.

* SQLite: added a "heap_limit" URL property. Makes SQLite 
  auto-release unused memory if memory usage goes above 
  the specified limit [KB]. Require that SQLite is
  compiled with the SQLITE_ENABLE_MEMORY_MANAGEMENT option
  to take effect.

Bug fixes:

* SQLite: Ensure that the database file is specified in
  connection URL. Thanks to Bogdan Nicula.

* PostgreSQL: Implemented Connection_setQueryTimeout()

--------------------------------------------------------------------------------
ChangeLog:

* Wed Dec  8 2010 Bernard Johnson <bjohnson symetrix com> - 2.7-1
- v 2.7
- change BR from flex to flex-static for F15 (bz #660879)
* Fri Aug 21 2009 Tomas Mraz <tmraz redhat com> - 2.6-3
- rebuilt with new openssl
* Thu Jul 30 2009 Jesse Keating <jkeating redhat com> - 2.6-2
- Bump for F12 mass rebuild
--------------------------------------------------------------------------------


================================================================================
 libzdb-2.7-1.el6 (FEDORA-EPEL-2011-0068)
 Small, fast, and easy to use database API
--------------------------------------------------------------------------------
Update Information:

This is a feature and bug fix release which has been tested on the following platforms:

 * Linux 2.6 (x86 and x64)
 * Mac OS X Snow Leopard (Darwin 10.6.x i386/x86_64)
 * Mac OS X Leopard (Darwin 10.5.x ppc)
 * FreeBSD 6.x, 7.x and 8.x (x86 and x64)
 * Solaris 10 and Solaris Express (sparc and x86)
 * OpenBSD 4.x (x86 and x64)


Release notes:
--------------

This release brings tentative Oracle support to libzdb thanks to Volodymyr Tarasenko. If you already have Oracle installed on your system, then simply running configure should pick it up. Otherwise if you want to build libzdb with Oracle support, but don't have Oracle installed (like me) it is a bit more work. Here's what I did; download Instant Client (basic and sdk) from http://www.oracle.com/ Create a oci directory someplace and copy header files and libs into this directory. Then use this configure statement; ./configure --with-oci-include=/<path>/oci/include --with-oci-lib=/<path>/oci/lib 

The Oracle implementation is not quite yet production ready which emerge from the change log below, though for most practical purposes it should work - according to Volodymyr. If you want to help out testing and improving it, please do.

The SQLite implementation has been further improved by adding a configure option to make SQLite release unused memory. This is very useful as SQLite does not care so much about releasing memory and its memory usage can grow considerably if left unchecked. 



Changes in this release:
------------------------

* Added tentative support for Oracle. Thanks to Volodymyr
  Tarasenko, and Sergey Pavlov for implementing this.
  This implementation does not support BLOB, though CLOB
  is supported. It will also not run all zdb unit tests,
  but should be useful for most purposes. It is released
  with the hope that others may still find it useful and
  help iron out any remaining issues.

* Added new convenience zdb.h meta include file which
  can be used to include all required API interfaces

* Internal optimizing changes and improvements - we simply
  adore refactoring

* SQLite: Clear connection on rollback to prevent SQLite
  from issue an SQLITE_BUSY error if there are pending
  selects in progress.

* SQLite: added a "heap_limit" URL property. Makes SQLite 
  auto-release unused memory if memory usage goes above 
  the specified limit [KB]. Require that SQLite is
  compiled with the SQLITE_ENABLE_MEMORY_MANAGEMENT option
  to take effect.

Bug fixes:

* SQLite: Ensure that the database file is specified in
  connection URL. Thanks to Bogdan Nicula.

* PostgreSQL: Implemented Connection_setQueryTimeout()

--------------------------------------------------------------------------------
ChangeLog:

* Wed Dec  8 2010 Bernard Johnson <bjohnson symetrix com> - 2.7-1
- v 2.7
- change BR from flex to flex-static for F15 (bz #660879)
* Fri Aug 21 2009 Tomas Mraz <tmraz redhat com> - 2.6-3
- rebuilt with new openssl
* Thu Jul 30 2009 Jesse Keating <jkeating redhat com> - 2.6-2
- Bump for F12 mass rebuild
--------------------------------------------------------------------------------


================================================================================
 perl-Getopt-GUI-Long-0.91-5.el5 (FEDORA-EPEL-2011-0072)
 A wrapper around Getopt::Long to provide a GUI to applications
--------------------------------------------------------------------------------
Update Information:

A portable Wizard-screen based form input system
--------------------------------------------------------------------------------


================================================================================
 python-jsonpickle-0.3.1-2.1.el5 (FEDORA-EPEL-2011-0070)
 A module that allows any object to be serialized into JSON
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #669553 - SCM Change Request - python-jsonpickle
        https://bugzilla.redhat.com/show_bug.cgi?id=669553
--------------------------------------------------------------------------------


================================================================================
 root-5.28.00-1.el5.1 (FEDORA-EPEL-2011-0074)
 Numerical data analysis framework
--------------------------------------------------------------------------------
Update Information:

The ROOT system provides a set of object oriented frameworks with all the functionality needed to handle and analyze large amounts of data in a very efficient way. Having the data defined as a set of objects, specialized storage methods are used to get direct access to the separate attributes of the selected objects, without having to touch the bulk of the data. Included are histogramming methods in 1, 2 and 3 dimensions, curve fitting, function evaluation, minimization, graphics and visualization classes to allow the easy setup of an analysis system that can query and process the data interactively or in batch mode.

Thanks to the built in CINT C++ interpreter the command language, the scripting, or macro, language and the programming language are all C++. The interpreter allows for fast prototyping of the macros since it removes the time consuming compile/link cycle. It also provides a good environment to learn C++. If more performance is needed the interactively developed macros can be compiled using a C++ compiler.

The system has been designed in such a way that it can query its databases in parallel on MPP machines or on clusters of workstations or high-end PCs. ROOT is an open system that can be dynamically extended by linking external libraries. This makes ROOT a premier platform on which to build data acquisition, simulation and data analysis systems.

--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #542990 - Review Request: root - Numerical data analysis framework
        https://bugzilla.redhat.com/show_bug.cgi?id=542990
--------------------------------------------------------------------------------



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]