[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora EPEL 6 updates-testing report



The following Fedora EPEL 6 Security updates need testing:

    https://admin.fedoraproject.org/updates/xml-security-c-1.6.0-2.el6
    https://admin.fedoraproject.org/updates/bugzilla-3.4.11-1.el6
    https://admin.fedoraproject.org/updates/rt3-3.8.10-2.el6.1
    https://admin.fedoraproject.org/updates/drupal7-7.6-1.el6
    https://admin.fedoraproject.org/updates/clamav-0.97.2-3.el6
    https://admin.fedoraproject.org/updates/cgit-0.9.0.2-2.el6
    https://admin.fedoraproject.org/updates/glpi-0.78.5-2.svn14966.el6
    https://admin.fedoraproject.org/updates/squirrelmail-1.4.22-2.el6
    https://admin.fedoraproject.org/updates/phpMyAdmin-3.4.3.2-1.el6
    https://admin.fedoraproject.org/updates/p7zip-9.20.1-2.el6
    https://admin.fedoraproject.org/updates/erlang-R14B-02.1.el6


The following builds have been pushed to Fedora EPEL 6 updates-testing

    BackupPC-3.2.1-1.el6
    bitlbee-3.0.3-2.el6
    clamav-0.97.2-3.el6
    curlpp-0.7.3-4.el6
    drupal6-features_extra-1.0-0.1.dev.el6
    drupal6-strongarm-2.0-1.el6
    drupal7-7.6-1.el6
    euca2ools-1.3.1-12.el6
    facter-1.6.0-2.el6
    gambit-c-4.6.1-1.el6
    gpodder-2.16-1.el6
    incron-0.5.9-1.el6
    libebml-1.2.1-1.el6
    libmatroska-1.2.0-1.el6
    mkvtoolnix-4.9.1-1.el6
    mock-1.1.12-1.el6
    mod_extract_forwarded-2.0.2-8.el6
    ncrack-0.4-0.1.ALPHA.el6
    nut-2.4.3-4.el6
    p7zip-9.20.1-2.el6
    paco-2.0.9-6.el6
    perl-Catalyst-Plugin-StackTrace-0.10-2.el6
    perl-Catalyst-View-JSON-0.30-1.el6
    perl-NetPacket-1.2.0-1.el6
    perl-NetPacket-LLC-0.01-2.el6
    php-pear-OLE-1.0.0-0.4.rc1.el6
    php-pecl-xdebug-2.1.2-1.el6
    python-confparser-1.0.0-3.el6
    python-confparser-1.0.0-4.el6
    python-dateutil15-1.5-1.el6
    python-fedora-0.3.24-1.el6
    python-httplib2-0.4.0-5.el6
    python-mygpoclient-1.5-2.el6
    qodem-0.3.2-1.el6
    rubygem-aws-sdk-1.0.2-1.el6
    shorewall-4.4.21.1-3.el6.1
    sombok-2.0.5-2.el6
    supybot-gribble-0.83.4.1-8.el6
    torque-2.5.7-1.el6

Details about builds:


================================================================================
 BackupPC-3.2.1-1.el6 (FEDORA-EPEL-2011-3942)
 High-performance backup system
--------------------------------------------------------------------------------
Update Information:

- v 3.2.1
- add lower case script URL alias for typing impaired
- cleanup selinux macros
- spec cleanup
- make samba dependency on actual files required to EL5 can use samba-client
  or samba3x-client (bz #667479)
- unbundle perl(Net::FTP::AutoReconnect) and perl(Net::FTP::RetrHandle)
- remove old patch that is no longer needed
- attempt to make sure $Conf{TopDir} is listed in updatedb PRUNEPATHS,
  otherwise at least generate a warning on statup (bz #554491)
- move sockets to /var/run (bz #719499)
- add support for systemd starting at F16 (bz #699441)
- patch to move pid dir under /var/run
- unbundle Net::FTP::*
- add support for tmpfiles.d
--------------------------------------------------------------------------------
ChangeLog:

* Fri Jul  8 2011 Bernard Johnson <bjohnson symetrix com> - 3.2.1-1
- v 3.2.1
- add lower case script URL alias for typing impaired
- cleanup selinux macros
- spec cleanup
- make samba dependency on actual files required to EL5 can use samba-client
  or samba3x-client (bz #667479)
- unbundle perl(Net::FTP::AutoReconnect) and perl(Net::FTP::RetrHandle)
- remove old patch that is no longer needed
- attempt to make sure $Conf{TopDir} is listed in updatedb PRUNEPATHS,
  otherwise at least generate a warning on statup (bz #554491)
- move sockets to /var/run (bz #719499)
- add support for systemd starting at F16 (bz #699441)
- patch to move pid dir under /var/run
- unbundle Net::FTP::*
- add support for tmpfiles.d
* Mon Feb  7 2011 Fedora Release Engineering <rel-eng lists fedoraproject org> - 3.1.0-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Mon Aug  2 2010 Johan Cwiklinski <johan AT x-tnd DOT be> 3.1.0-16
- Debugingo with no sources (fix bug #620257)
* Sat Jul 31 2010 Johan Cwiklinski <johan AT x-tnd DOT be> 3.1.0-15
- perl-suidperl is no longer available (fix bug #611009)
* Fri Jul  9 2010 Mike McGrath <mmcgrath redhat com> 3.1.0-14.1
- Rebuilding to fix perl-suidperl broken dep
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #667479 - BackupPC incompatible with samba3x
        https://bugzilla.redhat.com/show_bug.cgi?id=667479
  [ 2 ] Bug #554491 - /var/lib/BackupPC should be excluded from locate(1) database
        https://bugzilla.redhat.com/show_bug.cgi?id=554491
  [ 3 ] Bug #719499 - Socket file should be in /var/run/BackupPC/ instead of /var/log/
        https://bugzilla.redhat.com/show_bug.cgi?id=719499
  [ 4 ] Bug #699441 - Providing native systemd file for upcoming F15 Feature Systemd
        https://bugzilla.redhat.com/show_bug.cgi?id=699441
--------------------------------------------------------------------------------


================================================================================
 bitlbee-3.0.3-2.el6 (FEDORA-EPEL-2011-3974)
 IRC to other chat networks gateway
--------------------------------------------------------------------------------
Update Information:

New upstream version to fix Twitter troubles.
--------------------------------------------------------------------------------
ChangeLog:

* Mon Jul 25 2011 Matěj Cepl <mcepl redhat com> - 3.0.3-2
- One more fix to the systemd unit files (#705096)
* Wed Mar  9 2011 Matěj Cepl <mcepl redhat com> - 3.0.2-1
- New upstream release. We can eliminate parts which were already merged
  upstream (ssl_pending patch)
* Mon Feb  7 2011 Fedora Release Engineering <rel-eng lists fedoraproject org> - 3.0.1-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Sun Jan  9 2011 Matěj Cepl <mcepl redhat com> - 3.0.1-8
- Fix crash when no SRV record is provided (#668190); fix by Ricky Zhou
* Wed Dec 29 2010 Matěj Cepl <mcepl redhat com> - 3.0.1-7
- Adding more missing systemd-support pieces and eliminate xinetd on F<15
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #714032 - update bitlbee to 3.0.3, twitter doesn't work
        https://bugzilla.redhat.com/show_bug.cgi?id=714032
--------------------------------------------------------------------------------


================================================================================
 clamav-0.97.2-3.el6 (FEDORA-EPEL-2011-3963)
 Anti-virus software
--------------------------------------------------------------------------------
Update Information:


- updated to 0.97.2
- Build-require xz
- Handle tar.xz SOURCE0 on RHEL < 6
- CVE-2011-2721 Off-by-one error by scanning message hashes (#725694)
- include updated clamd-wrapper which get the PidFile setting from the service configuration file. 

--------------------------------------------------------------------------------
ChangeLog:

* Wed Jul 27 2011 Jan-Frode Myklebuust <janfrode tanso net> - 0.97.2-3
- include updated clamd-wrapper which get the PidFile setting from the
  service configuration file. 
- updated to 0.97.2
- Build-require xz
- CVE-2011-2721 Off-by-one error by scanning message hashes (#725694)
* Wed Jun 29 2011 Nick Bebout <nb fedoraproject org> - 0.97-14
- Require /usr/sbin/sendmail instead of sendmail
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #725695 - Clam AntiVirus: Off-by-one error by scanning message hashes [epel-all]
        https://bugzilla.redhat.com/show_bug.cgi?id=725695
--------------------------------------------------------------------------------


================================================================================
 curlpp-0.7.3-4.el6 (FEDORA-EPEL-2011-3980)
 A C++ wrapper for libcURL
--------------------------------------------------------------------------------
Update Information:

New package
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #723053 - Review Request: curlpp - a C++ wrapper for libcURL
        https://bugzilla.redhat.com/show_bug.cgi?id=723053
--------------------------------------------------------------------------------


================================================================================
 drupal6-features_extra-1.0-0.1.dev.el6 (FEDORA-EPEL-2011-3934)
 Features Extra provides faux exportables
--------------------------------------------------------------------------------
Update Information:

Features Extra provides faux exportables (via Features) of several
site-building components.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #723356 - Review Request: drupal6-features_extra - Features Extra provides faux exportables
        https://bugzilla.redhat.com/show_bug.cgi?id=723356
--------------------------------------------------------------------------------


================================================================================
 drupal6-strongarm-2.0-1.el6 (FEDORA-EPEL-2011-3958)
 Strongarm gives a way to override the default variable values
--------------------------------------------------------------------------------
Update Information:

Strongarm gives site builders a way to override the default variable values that Drupal core and contributed modules ship with. It is not an end user tool, but a developer and site builder tool which provides an API and a limited UI.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #725888 - Review Request: drupal6-strongarm - Strongarm gives a way to override the default variable values
        https://bugzilla.redhat.com/show_bug.cgi?id=725888
--------------------------------------------------------------------------------


================================================================================
 drupal7-7.6-1.el6 (FEDORA-EPEL-2011-3956)
 An open-source content-management platform
--------------------------------------------------------------------------------
Update Information:

Remember to log in as the admin user prior to RPM upgrade to perform DB upgrade.

* Advisory ID: DRUPAL-SA-CORE-2011-003
  * Project: Drupal core [1]
  * Version: 7.x
  * Date: 2011-July-27
  * Security risk: Less critical [2]
  * Exploitable from: Remote
  * Vulnerability: Access bypass

-------- DESCRIPTION  
---------------------------------------------------------

.... Access bypass in private file fields on comments.

Drupal 7 contains two new features: the ability to attach File upload fields
to any entity type in the system and the ability to point individual File
upload fields to the private file directory.

If a Drupal site is using these features on comments, and the parent node is
denied access (either by a node access module or by being unpublished), the
file attached to the comment can still be downloaded by non-privileged users
if they know or guess its direct URL.

This issue affects Drupal 7.x only.

-------- VERSIONS AFFECTED  
---------------------------------------------------

  * Drupal 7.x before version 7.5.

-------- SOLUTION  
------------------------------------------------------------

Install the latest version:

  * If you are running Drupal 7.x then upgrade to Drupal 7.5 or 7.6.

The Security Team has released both a pure security update without other bug
fixes and a security update combined with other bug fixes and improvements.
You can choose to either only include the security update for an immediate
fix (which might require less quality assurance and testing) or more fixes
and improvements alongside the security fixes by choosing between Drupal 7.5
and Drupal 7.6. Read the announcement [3] for more information.

See also the Drupal core [4] project page.

-------- REPORTED BY  
---------------------------------------------------------

  * The File access bypass was reported by Florian Weber [5].

-------- FIXED BY  
------------------------------------------------------------

  * The File access bypass was fixed by Stéphane Corlosquet [6] and Károly
    Négyesi [7], both members of the Drupal security team.

-------- CONTACT AND MORE INFORMATION  
----------------------------------------

The Drupal security team can be reached at security at drupal.org or via the
contact form at http://drupal.org/contact [8].

Learn more about the Drupal Security team and their policies [9], writing
secure code for Drupal [10], and securing your site [11].


[1] http://drupal.org/project/drupal
[2] http://drupal.org/security-team/risk-levels
[3] http://drupal.org/drupal-7.6
[4] http://drupal.org/project/drupal
[5] http://drupal.org/user/254778
[6] http://drupal.org/user/52142
[7] http://drupal.org/user/9446
[8] http://drupal.org/contact
[9] http://drupal.org/security-team
[10] http://drupal.org/writing-secure-code
[11] http://drupal.org/security/secure-configuration

--------------------------------------------------------------------------------
ChangeLog:

* Wed Jul 27 2011 Jon Ciesla <limb jcomserv net> - 7.6-1
- New upstream, SA-CORE-2011-003, BZ 726243.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #726222 - drupal7: access bypass vulnerability in 7.x  (SA-CORE-2011-003)
        https://bugzilla.redhat.com/show_bug.cgi?id=726222
--------------------------------------------------------------------------------


================================================================================
 euca2ools-1.3.1-12.el6 (FEDORA-EPEL-2011-3927)
 Elastic Utility Computing Architecture Command-Line Tools
--------------------------------------------------------------------------------
Update Information:

This update fixes registration of EBS-backed images and adds support for bundle-upload location constraints.
--------------------------------------------------------------------------------
ChangeLog:

* Fri Jul 22 2011 Garrett Holmstrom <gholms fedoraprojecto rg> - 1.3.1-12
- Fixed registration of EBS-backed images
* Fri Jul  1 2011 Garrett Holmstrom <gholms fedoraproject org> - 1.3.1-11
- Backported support for bundle upload location constraints [LP:704658]
* Fri Jun 10 2011 Garrett Holmstrom <gholms fedoraproject org> - 1.3.1-11
- Fixed handling of empty block device sizes
- Fixed euca-describe-image-attribute -B output [LP:795395]
--------------------------------------------------------------------------------


================================================================================
 facter-1.6.0-2.el6 (FEDORA-EPEL-2011-3926)
 Ruby module for collecting simple facts about a host operating system
--------------------------------------------------------------------------------
Update Information:

Upstream bugfix release.  Highlights:

* Change license from GPLv2+ to ASL 2.0
* Speed Improvements
* Fact Detection Improvements
* Documentation

Refer to the upstream release notes for more details:

http://projects.puppetlabs.com/projects/facter/wiki
--------------------------------------------------------------------------------
ChangeLog:

* Wed Jul 27 2011 Todd Zullinger <tmz pobox com> - 1.6.0-2
- Update license tag, GPLv2+ -> ASL 2.0
* Thu Jul 14 2011 Todd Zullinger <tmz pobox com> - 1.6.0-1
- Update to 1.6.0
--------------------------------------------------------------------------------


================================================================================
 gambit-c-4.6.1-1.el6 (FEDORA-EPEL-2011-3941)
 Scheme programming system
--------------------------------------------------------------------------------
Update Information:

Latest upstream release
--------------------------------------------------------------------------------
ChangeLog:

* Wed Jul 27 2011 Michel Salim <salimma fedoraproject org> - 4.6.1-1
- Update to 4.6.1
* Tue Feb  8 2011 Fedora Release Engineering <rel-eng lists fedoraproject org> - 4.6.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #691035 - gambit-c-4.6.1 is available
        https://bugzilla.redhat.com/show_bug.cgi?id=691035
--------------------------------------------------------------------------------


================================================================================
 gpodder-2.16-1.el6 (FEDORA-EPEL-2011-3968)
 Podcast receiver/catcher written in Python
--------------------------------------------------------------------------------
Update Information:

New upstream release, built for EPEL-6
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #725113 - gpodder 2.16 was released on 2011-07-07.
        https://bugzilla.redhat.com/show_bug.cgi?id=725113
--------------------------------------------------------------------------------


================================================================================
 incron-0.5.9-1.el6 (FEDORA-EPEL-2011-3925)
 Inotify cron system
--------------------------------------------------------------------------------
Update Information:

Build for EPEL 6
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #725677 - incron missing in EPEL6
        https://bugzilla.redhat.com/show_bug.cgi?id=725677
--------------------------------------------------------------------------------


================================================================================
 libebml-1.2.1-1.el6 (FEDORA-EPEL-2011-3982)
 Extensible Binary Meta Language library
--------------------------------------------------------------------------------
Update Information:

This package will allow to create content using the mkv container.
It may break with package using an older version of the ABI that are provided outside EPEL. (such as vlc)

This package will stay in testing until the well known third part will use this ABI.



--------------------------------------------------------------------------------


================================================================================
 libmatroska-1.2.0-1.el6 (FEDORA-EPEL-2011-3982)
 Open audio/video container format library
--------------------------------------------------------------------------------
Update Information:

This package will allow to create content using the mkv container.
It may break with package using an older version of the ABI that are provided outside EPEL. (such as vlc)

This package will stay in testing until the well known third part will use this ABI.



--------------------------------------------------------------------------------


================================================================================
 mkvtoolnix-4.9.1-1.el6 (FEDORA-EPEL-2011-3982)
 Matroska container manipulation utilities
--------------------------------------------------------------------------------
Update Information:

This package will allow to create content using the mkv container.
It may break with package using an older version of the ABI that are provided outside EPEL. (such as vlc)

This package will stay in testing until the well known third part will use this ABI.



--------------------------------------------------------------------------------


================================================================================
 mock-1.1.12-1.el6 (FEDORA-EPEL-2011-3950)
 Builds packages inside chroots
--------------------------------------------------------------------------------
Update Information:

* Tue Jul 26 2011 Clark Williams <williams redhat com> - 1.0.19-1
- fixed incorrect python version requirement [BZ# 718376]
- remove f13 configs
- added exception for unshare(2) failures [BZ# 718714]
- added back 'newinstance' mount option to devpts (with symlink logic)
- fixed epel-6-* configurations [BZ# 679885, 719740]
- from Matt Domsch <Matt_Domsch dell com>
  - tmpfs plugin typo fix

removed 'newinstance' option from devpts mount in chroot
added Fedora 16 configuration files
Fix inconsistent permissions fixing on /var/cache/mock in SPEC template
modify --chroot command to print command output
update the python requirement to >= 2.6 for 1.1.x mock branch

--------------------------------------------------------------------------------
ChangeLog:

* Tue Jul 26 2011 Clark Williams <williams redhat com> - 1.1.12-1
- remove f13 configs
- added exception for unshare(2) failures [BZ# 718714]
- added back 'newinstance' mount option to devpts (with symlink logic)
- fixed epel-6-* configurations [BZ# 679885, 719740]
- from Matt Domsch <Matt_Domsch dell com>
  - tmpfs plugin typo fix
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #718376 - Unsatisfied dependency on python >= 2.6
        https://bugzilla.redhat.com/show_bug.cgi?id=718376
  [ 2 ] Bug #718714 - INFO: Namespace unshare failed => build failure
        https://bugzilla.redhat.com/show_bug.cgi?id=718714
  [ 3 ] Bug #679885 - mock fails to build packages for EPEL 6
        https://bugzilla.redhat.com/show_bug.cgi?id=679885
--------------------------------------------------------------------------------


================================================================================
 mod_extract_forwarded-2.0.2-8.el6 (FEDORA-EPEL-2011-3978)
 Extract real source IP for forwarded HTTP requests
--------------------------------------------------------------------------------
Update Information:

mod_extract_forwarded for EPEL6
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #716993 - mod_extract_forwarded missing in EPEL 6
        https://bugzilla.redhat.com/show_bug.cgi?id=716993
--------------------------------------------------------------------------------


================================================================================
 ncrack-0.4-0.1.ALPHA.el6 (FEDORA-EPEL-2011-3951)
 High-speed network auth cracking tool
--------------------------------------------------------------------------------
Update Information:

Update for upstream release.

This includes bugfixes and new features.
--------------------------------------------------------------------------------
ChangeLog:

* Wed Jul 27 2011 Steve Milner <smilner fedoraproject org> 0.4-0.1.ALPHA
- Update for upstream release.
- Update spec changelog to fedora address
* Tue Feb  8 2011 Fedora Release Engineering <rel-eng lists fedoraproject org> - 0.3-0.2.ALPHA
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #722772 - New ncrack release available
        https://bugzilla.redhat.com/show_bug.cgi?id=722772
--------------------------------------------------------------------------------


================================================================================
 nut-2.4.3-4.el6 (FEDORA-EPEL-2011-3948)
 Network UPS Tools
--------------------------------------------------------------------------------
Update Information:

- add nut-monitor (gui) to client sub-package
--------------------------------------------------------------------------------
ChangeLog:

* Wed Jul 27 2011 Michal Hlavinka <mhlavink redhat com> - 2.4.3-4
- add nut-monitor (gui) to client sub-package
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #725907 - nut-monitor is missing
        https://bugzilla.redhat.com/show_bug.cgi?id=725907
--------------------------------------------------------------------------------


================================================================================
 p7zip-9.20.1-2.el6 (FEDORA-EPEL-2011-3929)
 Very high compression ratio file archiver
--------------------------------------------------------------------------------
Update Information:

New release, with new features, optimizations and bug fixes.
--------------------------------------------------------------------------------
ChangeLog:

* Tue Jul 26 2011 Matthias Saou <matthias saou eu> 9.20.1-2
- Execstack patch to fix what's wanted by the yasm code (#718778).
* Tue Jul 26 2011 Matthias Saou <matthias saou eu> 9.20.1-1
- Update to 9.20.1 (#688564).
- Update norar, nostrip and install patches.
- Minor clean ups : Don't use trivial macros + new email address.
- Don't require the main package from the plugins package (#690551).
- Use the any_cpu_gcc_4.X makefile for ppc* since the ppc specific one is gone.
* Tue Feb  8 2011 Fedora Release Engineering <rel-eng lists fedoraproject org> - 9.13-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #718778 - Executable stack required in p7zip plugins
        https://bugzilla.redhat.com/show_bug.cgi?id=718778
--------------------------------------------------------------------------------


================================================================================
 paco-2.0.9-6.el6 (FEDORA-EPEL-2011-3983)
 A source code package organizer for Unix/Linux
--------------------------------------------------------------------------------
Update Information:

New package
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #705043 - Review Request: paco - a source code package organizer for Unix
        https://bugzilla.redhat.com/show_bug.cgi?id=705043
--------------------------------------------------------------------------------


================================================================================
 perl-Catalyst-Plugin-StackTrace-0.10-2.el6 (FEDORA-EPEL-2011-3977)
 Display a stack trace on the debug screen
--------------------------------------------------------------------------------
Update Information:

This is a new package in EPEL 6.
--------------------------------------------------------------------------------


================================================================================
 perl-Catalyst-View-JSON-0.30-1.el6 (FEDORA-EPEL-2011-3932)
 JSON view for your data
--------------------------------------------------------------------------------
Update Information:

This is a new package in EPEL 6.
--------------------------------------------------------------------------------


================================================================================
 perl-NetPacket-1.2.0-1.el6 (FEDORA-EPEL-2011-3955)
 Assemble/disassemble network packets at the protocol level
--------------------------------------------------------------------------------
Update Information:

Update to version 1.2.0
--------------------------------------------------------------------------------
ChangeLog:

* Sat Jul 30 2011 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.2.0-1
- Update to 1.2.0.
* Fri Jun 17 2011 Marcela Mašláňová <mmaslano redhat com> - 1.1.1-2
- Perl mass rebuild
--------------------------------------------------------------------------------


================================================================================
 perl-NetPacket-LLC-0.01-2.el6 (FEDORA-EPEL-2011-3931)
 Assemble and disassemble IEEE 802.3 LLC protocol packets
--------------------------------------------------------------------------------
Update Information:

update to latest upstream version
--------------------------------------------------------------------------------


================================================================================
 php-pear-OLE-1.0.0-0.4.rc1.el6 (FEDORA-EPEL-2011-3953)
 Package for reading and writing OLE containers
--------------------------------------------------------------------------------
Update Information:

This package allows reading and writing of OLE (Object Linking and Embedding) compound documents. This format is used as container for Excel (.xls), Word (.doc) and other Microsoft file formats.
--------------------------------------------------------------------------------


================================================================================
 php-pecl-xdebug-2.1.2-1.el6 (FEDORA-EPEL-2011-3973)
 PECL package for debugging PHP scripts
--------------------------------------------------------------------------------
Update Information:

Upstream changelog:

Version 2.1.2:

* Fixed bug #622: Working with eval() code is inconvenient and difficult.
* Fixed bug #684: xdebug_var_dump - IE does not support &.
* Fixed bug #693: Cachegrind files not written when filename is very long.
* Fixed bug #697: Incorrect code coverage of function arguments when using XDEBUG_CC_UNUSED.
* Fixed bug #699: Xdebug gets the filename wrong for the countable interface.
* Fixed bug #703 by adding another opcode to the list that needs to be overridden.

Version 2.1.1:

= Debugger
* Fixed bug #518: Removed CLASSNAME pseudo-property optional.
* Fixed bug #592: Xdebug crashes with run after detach.
* Fixed bug #596: Call breakpoint never works with instance methods, only static methods.
* Fixed JIT mode in the debugger so that it works for xdebug_break() too.

= Profiler
* Fixed bug #631: Summary not written when script ended with "exit()".
* Fixed bug #639: Xdebug profiling: output not correct - missing 'cfl='.
* Fixed bug #642: Fixed line numbers for offsetGet, offsetSet, __get/__set/__isset/__unset and __call in profile files and stack traces/function traces.
* Fixed bug #643: Profiler gets line numbers wrong.
* Fixed bug #653: XDebug profiler crashes with %H in file name and non standard port.
--------------------------------------------------------------------------------
ChangeLog:

* Thu Jul 28 2011 Remi Collet <Fedora FamilleCollet com> - 2.1.2-1
- update to 2.1.2
- fix provides filter for rpm 4.9
- improved description
--------------------------------------------------------------------------------


================================================================================
 python-confparser-1.0.0-3.el6 (FEDORA-EPEL-2011-3984)
 A KISS python module to parse *nix config files
--------------------------------------------------------------------------------
Update Information:

new package
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #725552 - Review Request: python-confparser - A KISS parse to *nix config files
        https://bugzilla.redhat.com/show_bug.cgi?id=725552
--------------------------------------------------------------------------------


================================================================================
 python-confparser-1.0.0-4.el6 (FEDORA-EPEL-2011-3935)
 A KISS python module to parse *nix config files
--------------------------------------------------------------------------------
Update Information:

updated spec to fix EPEL5 compilation
--------------------------------------------------------------------------------


================================================================================
 python-dateutil15-1.5-1.el6 (FEDORA-EPEL-2011-3947)
 Powerful extensions to the standard datetime module
--------------------------------------------------------------------------------
Update Information:

Parallel installable newer version of python-dateutil for EPEL 6 only
--------------------------------------------------------------------------------


================================================================================
 python-fedora-0.3.24-1.el6 (FEDORA-EPEL-2011-3959)
 Python modules for talking to Fedora Infrastructure Services
--------------------------------------------------------------------------------
Update Information:

* Fix a bug with auth for TG2 servers
* Fix a bug in client auth using F15+ pycurl
--------------------------------------------------------------------------------
ChangeLog:

* Wed Jul 20 2011 Toshio Kuratomi <toshio fedoraproject org> - 0.3.24-1
- Upstream 0.3.24 release bugfixing TG2 server utils and clients with
  session cookie auth.
--------------------------------------------------------------------------------


================================================================================
 python-httplib2-0.4.0-5.el6 (FEDORA-EPEL-2011-3922)
 A comprehensive HTTP client library
--------------------------------------------------------------------------------
Update Information:

This update address python-httplib2 issue 39 and
Bug 726558 - Zanata deployment issue in RHEL6
--------------------------------------------------------------------------------
ChangeLog:

* Fri Jul 29 2011 Ding-Yi Chen <dchen at redhat.com>  - 0.4.0-5
- Apply that address python-httplib2 (GoogleCode Hosted) issue 39
  http://code.google.com/p/httplib2/issues/detail?id=39
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #726558 - Zanata deployment issue in RHEL6
        https://bugzilla.redhat.com/show_bug.cgi?id=726558
--------------------------------------------------------------------------------


================================================================================
 python-mygpoclient-1.5-2.el6 (FEDORA-EPEL-2011-3972)
 Python module to connect to the my.gpodder.org webservice
--------------------------------------------------------------------------------
Update Information:

New build to make gpodder available in EL-6.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #725157 - Please, create EL6 branch in EPEL
        https://bugzilla.redhat.com/show_bug.cgi?id=725157
--------------------------------------------------------------------------------


================================================================================
 qodem-0.3.2-1.el6 (FEDORA-EPEL-2011-3961)
 Terminal emulator and communications package
--------------------------------------------------------------------------------
Update Information:

Qodem is an open-source re-implementation of the Qmodem(tm)
shareware communications package, updated for more modern uses.
Major features include:
    * Unicode display: translation of CP437 (PC VGA), VT100 DEC
      Special Graphics characters, VT220 National Replacement
      Character sets, etc., to Unicode
    * Terminal interface conveniences: scrollback buffer, capture
      file, screen dump, dialing directory, keyboard macros, script
      support
    * Connection methods: serial, local shell, command line, telnet,
      ssh, rlogin, rsh
    * Emulations: ANSI.SYS (including "ANSI music"), Avatar, VT52,
      VT100/102, VT220, Linux, and XTerm
    * Transfer protocols: Xmodem, Ymodem, Zmodem, and Kermit

--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #725267 - Review Request: qodem - Qodem terminal emulator and communications package
        https://bugzilla.redhat.com/show_bug.cgi?id=725267
--------------------------------------------------------------------------------


================================================================================
 rubygem-aws-sdk-1.0.2-1.el6 (FEDORA-EPEL-2011-3943)
 AWS SDK for Ruby
--------------------------------------------------------------------------------
Update Information:

New upstream version: 1.0.2.
New package: rubygem-aws-sdk - AWS SDK for Ruby
New package: rubygem-aws-sdk - AWS SDK for Ruby
New package: rubygem-aws-sdk - AWS SDK for Ruby
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #723472 - Review Request: rubygem-aws-sdk - AWS SDK for Ruby
        https://bugzilla.redhat.com/show_bug.cgi?id=723472
--------------------------------------------------------------------------------


================================================================================
 shorewall-4.4.21.1-3.el6.1 (FEDORA-EPEL-2011-3981)
 An iptables front end for firewall configuration
--------------------------------------------------------------------------------
Update Information:

Fix executable permissions on helper programs.
Release notes:

http://www1.shorewall.net/pub/shorewall/4.4/shorewall-4.4.21/releasenotes.txt

New upstream bugfix version. Release notes:
http://www1.shorewall.net/pub/shorewall/4.4/shorewall-4.4.17/releasenotes.txt
--------------------------------------------------------------------------------
ChangeLog:

* Sat Jul 23 2011 Jonathan G. Underwood <jonathan underwood gmail com> - 4.4.21.1-3.1
- Make files in libexec directory executable
* Thu Jul 21 2011 Jonathan G. Underwood <jonathan underwood gmail com> - 4.4.21-3
- Properly use PERLLIB environment variable for installation of the perl libraries
* Thu Jul 21 2011 Jonathan G. Underwood <jonathan underwood gmail com> - 4.4.21-2
- Fix Source URL versioning in spec file
* Thu Jul 21 2011 Jonathan G. Underwood <jonathan underwood gmail com> - 4.4.21-1
- Update to 4.4.21.1
- Fix BZ 720713 (incorrect init file LSB headers)
* Wed May 25 2011 Orion Poplawski <orion cora nwra com> - 4.4.19.4-1
- Update to 4.4.19.4
* Sat Mar  5 2011 Jonathan G. Underwood <jonathan underwood gmail com> - 4.4.17-2
- Add executable permission to getparams
* Mon Feb 14 2011 Jonathan G. Underwood <jonathan underwood gmail com> - 4.4.17-1
- Update to 4.4.17
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #720713 - Copy-and-paste error in /etc/rc.d/init.d/shorewall6
        https://bugzilla.redhat.com/show_bug.cgi?id=720713
  [ 2 ] Bug #654787 - shorewall-4.4.21 is available
        https://bugzilla.redhat.com/show_bug.cgi?id=654787
--------------------------------------------------------------------------------


================================================================================
 sombok-2.0.5-2.el6 (FEDORA-EPEL-2011-3960)
 Unicode Text Segmentation Package
--------------------------------------------------------------------------------
Update Information:

First release of sombok.
Sombok library package performs Line Breaking Algorithm described in Unicode Standards Annex #14 (UAX #14). East_Asian_Width informative properties defined by Annex #11 (UAX #11) may be concerned to determine breaking positions. This package also implements "default" Grapheme Cluster segmentation described in Annex #29 (UAX #29).
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #705319 - Review Request: sombok - Unicode Text Segmentation Package
        https://bugzilla.redhat.com/show_bug.cgi?id=705319
--------------------------------------------------------------------------------


================================================================================
 supybot-gribble-0.83.4.1-8.el6 (FEDORA-EPEL-2011-3946)
 Cross-platform support bot based on supybot
--------------------------------------------------------------------------------
Update Information:

Here is where you
give an explanation of
your update.
Here is where you
give an explanation of
your update.
Here is where you
give an explanation of
your update.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #693664 - Review Request: supybot-gribble - Cross-platform support bot based on supybot
        https://bugzilla.redhat.com/show_bug.cgi?id=693664
--------------------------------------------------------------------------------


================================================================================
 torque-2.5.7-1.el6 (FEDORA-EPEL-2011-3928)
 Tera-scale Open-source Resource and QUEue manager
--------------------------------------------------------------------------------
Update Information:

**Warning: Significant change, munge enabled - action required:**

The updated EPEL6 build of torque-2.5.7-1 as compared to previous versions enables munge[1] as an inter node authentication method.

It is highly advisable that prior to upgrading to version 2.5.7-1 of this torque package that munge is installed and enabled. A munge package[2] is of course available within EPEL6.

 * [1] http://code.google.com/p/munge/
 * [2] https://admin.fedoraproject.org/community/?package=munge#package_maintenance

**ChangeLog:**

2.5.7:

 * e - Added new qsub argument -F. This argument takes a quoted string as an argument. The string is a list of space separated commandline arguments which are available to the job script. 
 * e - Added an option to asynchronously delete jobs (currently cannot work for qdel -a all due to limitations of single threads) backported from 3.0.2
 * c - Fix an issue where job_purge didn't protect key variables that resulted in crashes
 * b - fix bugzilla #134, qmgr -= was deleting all entries (backported from 3.0.2)
 * b - do not prepend ${HOME} with the current dir for -o and -e in qsub (backported from 3.0.2)
 * b - fix jobs named with -J not always having the server name appended correctly (backported from 3.0.2)
 * b - make it so that jobs named like arrays via -J have legal output and error file names (backported from 3.0.2)
 * b - Fixed a bug for high availability. The -l listener option for pbs_server was not complete and did not allow pbs_server to properly communicate with the scheduler. Also fixed a bug with job dependencies where the second server or later in the $TORQUE_HOME/server_name directory was not added as part of the job dependecny so dependent jobs would get stuck on hold if the current server was not the first server in the server_name file.
 * b - Fixed a potential buffer overflow problem in src/resmom/checkpoint.c function mom_checkpoint_recover. I modified the code to change strcpy and strcat to strncpy and strncpy.

2.5.6

 * b - Made changes to record_jobinfo and supporting functions to be able to use dynamically allcated buffers for data. This fixed a problem where incoming data overran fixed sized buffers.
 * b - restored functionality for -W umask as reported in bugzilla 115 (backported from 3.0.1)
 * b - Updated torque.spec.in to be able to handle the snapshot names of builds.
 * e - Added new MOM configure option job_starter. This options will execute the script submitted in qsub to the executable or script provided as the argument to the job_starter option of the MOM configure file.
 * b - fix pbs_mom -q to work with parallel jobs (backported from 3.0.1)
 * b - fixed a problem with pbs_server high availability where the current server could not keep the HA lock. The problem was a result of truncating the directory name where the lock file was kept. TORQUE would fail to validate permissions because it would do a stat on the wrong directory.
 * b - Added code to free the mom.lock file during MOM shutdown.
 * b - fixed a bug in set_resources that prevented the last resource in a list from being checked. As a result the last item in the list would always be added without regard to previous entries.
 * e - Added new symbol JOB_EXEC_OVERLIMIT. When a job exceeds a limit (i.e. walltime) the job will fail with the JOB_EXEC_OVERLIMIT value and also produce an abort case for mailing purposes. Previous to this change a job exceeding a limit returned 0 on success and no mail was sent to the user if requested on abort.
 * e - Added options to buildutils/torque.spec.in to conditionally build munge, BLCR, high-availability, cpusets, and spooling. Also allows customization of the sendmail path and allows for optional XML conversion to serverdb.
 * b - --with-tcp-retry-limit now actually changes things without needing to run autoheader
 * e - Added a new queue resource named procct. procct allows the administrator to set queue limits based on the number of total processors requested in a job. Patch provided by Martin Siegert.
 * e - allow more than 5 concurrent connections to TORQUE using pbsD_connect. Increase it to 10 (backported from 3.0.1)
 * b - fix a segfault when receiving an obit for a job that no longer exists (backported from 3.0.1)
 * b - also remove the procct resource when it is applied because of a default (backported from 3.0.1)
 * e - allow an administator using the proxy user submission to also set the job id to be used in TORQUE. This makes TORQUE easier to use in grid configurations. (backported from 3.0.2)
 * c - fix a segfault when queue has acl_group_enable and acl_group_sloppy set true and no acl_groups are defined. (backported from 3.0.1)
 * f - Added the ability to detect Nvidia gpus using nvidia-smi (default) or NVML. Server receives gpu statuses from pbs_mom. Added server attribute auto_node_gpu that allows automatically setting number of gpus for nodes based on gpu statuses. Added new configure options --enable-nvidia-gpus, --with-nvml-include and --with-nvml-lib.
 * e - The -e and -o options of qsub allow a user to specify a path or optionally a filename for output. If the path given by the user ended with a directory name but no '/' character at the end then TORQUE was confused and would not convert the .OU or .ER file to the final output/error file. The code has now been changed to stat the path to see if the end path element is a path or directory and handled appropriately.
 * c - fix a segfault when using --enable-nvidia-gpus and pbs_mom has Nvidia driver older than 260 that still has nvidia-smi command
 * e - Added new MOM configuration option $rpp_throttle. The syntax for this in the $TORQUE_HOME/mom_priv/config file is $rpp_throttle <value> where value is a long representing microseconds. Setting this values causes rpp data to pause after every sendto for <value> microseconds. This may help with large jobs where full data does not arrive at sister nodes.
 * c - check if the file pointer to /dev/console can be opened. If not, don't attempt to write it (backported from 3.0.2)
 * b - Added patch from Michael Jennings to buildutils/torque.spec.in. This patch allows an rpm configured with DRMAA to complete even if all of the support files are not present on the system.
 * b - commited patch submitted by Michael Jennings to fix bug 130. TORQUE on the MOM would call lstat as root when it should call it as user in open_std_file.
 * e - Added capability to automatically set mode on Nvidia gpus. Added support for gpu reseterr option on qsub. Removed server attribute auto_node_gpu. The nodes file will be updated with Nvidia gpu count when --enable-nvidia-gpu configure option is used. Moved some code out of job_purge_thread to prevent segfault on mom.


--------------------------------------------------------------------------------
ChangeLog:

* Tue Jul 26 2011 Steve Traylen <steve traylen cern ch> - 2.5.7-1
- Update to 2.5.7, drop torque-buffer-overrun-2.5.5.patch,
  Add man pages for: qgpumod, qgpureset, pbs_gpumode and 
  pbs_gpureset.
- Add or rather force munge support, Add torque-munge-size.patch.
--------------------------------------------------------------------------------



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]