[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

postgresql vs postgresql84



I maintain the package UpTools-8.5.5-2.el5.i386.rpm that is in epel5
testing, but has dependency problems:


postgresql84-devel-8.4.7-1.el5_6.1.i386 from installed has depsolving problems
  --> postgresql84-devel conflicts with postgresql-devel
postgresql84-8.4.7-1.el5_6.1.i386 from installed has depsolving problems
  --> postgresql84 conflicts with postgresql
Error: postgresql84 conflicts with postgresql
Error: postgresql84-devel conflicts with postgresql-devel
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


So I've modified the spec in order to use postgresql84 as requires but
now it outputs:


Transaction Check Error:
  file /usr/lib/libpq.so.4.1 from install of
postgresql-libs-8.1.23-1.el5_6.1.i386 conflicts with file from package
postgresqlclient81-8.1.11-1.el5s2.i386


What is the proper way to approach this issue?

Thanks in advance!

Transaction Check Error:
  file /usr/lib/libpq.so.4.1 from install of
postgresql-libs-8.1.23-1.el5_6.1.i386 conflicts with file from package
postgresqlclient81-8.1.11-1.el5s2.i386



-- 
--
Sergio Belkin  http://www.sergiobelkin.com
Watch More TV http://sebelk.blogspot.com
LPIC-2 Certified - http://www.lpi.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]