[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: libmodplug conflict between ATRPMS and EPEL for EL6



On 03/07/2011 05:59 PM, David Crick wrote:

libmodplug-0.8.7-2.el6.x86_64 - as provided by ATRPMS
libmodplug-0.8.8.1-2.el6.x86_64 - as provided by EPEL

I understand that the 3rd party repositories try their best
not to have dependency clashes between each other,
hence I am bringing it to the attention of both projects.

The problem probably comes from that 0.8.7 and 0.8.8.1 have different sonames, and that packages in each repo have been built against their version of libmodplug.

Because the EPEL version is up to date, I think this would be best solved in ATrpms side, for example by shipping a libmodplug088 or libmodplug1 (where "1" comes from the bumped soname in 0.8.8.1+) or something at least for a while, and then rebuilding dependent packages against it. After completing that process, I guess it wouldn't matter for end users whether the EPEL libmodplug or ATrpms libmodplug088 would be installed.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]