[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Meeting summary/minutes from today's EPEL sig meeting (2011-03-14)



On 2011-03-14, Kevin Fenzi <kevin scrye com> wrote:
> * clamav  (nirik, 20:40:16)
> 20:40:16 <nirik> #topic clamav
> 20:48:35 <nb> i think he is having problems with the requires/obsoletes
> 20:48:49 <nb> but i wonder if it is because he isn't yum localinstall'ing a=
> ll of the rpms in one transaction

I'm unable to figure out the dependency problems for 
old clamav-filesystem on RHEL5.

	# yum localinstall clamav-db-0.97-8.el5.x86_64.rpm clamd-0.97-8.el5.x86_64.rpm clamav-0.97-8.el5.x86_64.rpm 
	Setting up Local Package Process
	Examining clamav-0.97-8.el5.x86_64.rpm: clamav-0.97-8.el5.x86_64
	Marking clamav-0.97-8.el5.x86_64.rpm as an update to clamav-0.95.1-1.el5.x86_64
	Examining clamav-db-0.97-8.el5.x86_64.rpm: clamav-db-0.97-8.el5.x86_64
	Marking clamav-db-0.97-8.el5.x86_64.rpm to be installed
	Examining clamd-0.97-8.el5.x86_64.rpm: clamd-0.97-8.el5.x86_64
	Marking clamd-0.97-8.el5.x86_64.rpm to be installed
	Resolving Dependencies
	--> Running transaction check
	---> Package clamav.x86_64 0:0.97-8.el5 set to be updated
	---> Package clamav-db.x86_64 0:0.97-8.el5 set to be updated
	---> Package clamd.x86_64 0:0.97-8.el5 set to be updated
	--> Processing Conflict: clamav-filesystem conflicts clamav > 0.95.1-1.el5
	--> Finished Dependency Resolution
	clamav-filesystem-0.95.1-1.el5.x86_64 from installed has depsolving problems
  	--> clamav-filesystem conflicts with clamav
	Error: clamav-filesystem conflicts with clamav
 	You could try using --skip-broken to work around the problem
 	You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
	The program package-cleanup is found in the yum-utils package.

This was with clamav-db obsoleting and providing clamav-filesystem:

	Provides: clamav-filesystem = %{version}-%{release}
	Obsoletes: clamav-filesystem < %{version}-%{release}

I'm now wondering if there might be a problem with the old
clamav-filesystem package. It has some conflicts listed (which
I don't know what means":

# rpm -q --queryformat 'CONFLICTS: %{CONFLICTS}\nCONFLICTVERSION: %{CONFLICTVERSION}\nCONFLICTFLAGS: %{CONFLICTFLAGS}\nCONFLICTNAME: %{CONFLICTNAME}\n' clamav-filesystem
CONFLICTS: clamav
CONFLICTVERSION: 0.95.1-1.el5
CONFLICTFLAGS: 2
CONFLICTNAME: clamav

Looking at the old spec-file, it the clamav-filesystem package has:

	Conflicts:      %name < %version-%release
	Conflicts:      %name > %version-%release

	http://fpaste.org/6PwF/

But -- I still don't understand why this isn't resolved when upgrading
clamav-db obsoletes and provides clamav-filesystem. Is the problem maybe
that during the upgrade both packages will be installed, and that 
triggers this conflict ?

Any suggestions for how to fix this ?


  -jf


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]