[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RHEL 5.6 and PHP 5.3



Am 23.03.2011 02:36, schrieb Chris Adams:
Now that RHEL 5.6 has added PHP 5.3 (php53-* packages), is there any
plan on what to do with the EPEL PHP packages?  If I did my query right,
it looks like the following EPEL packages are built for PHP 5.1 only (by
source RPM):

    libpuzzle
    php-extras
    php-facedetect
    php-idn
    php-magickwand
    php-pecl-Fileinfo
    php-pecl-geoip
    php-pecl-gmagick
    php-pecl-imagick
    php-pecl-json
    php-pecl-lzf
    php-pecl-mailparse
    php-pecl-mongo
    php-pecl-radius
    php-pecl-runkit
    php-pecl-xdebug
    php-pecl-zip


I think phpMyAdmin has the same problem:

yum install phpMyAdmin.noarch
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:2.11.11.3-1.el5 set to be updated
--> Processing Dependency: php-mcrypt >= 4.1.0 for package: phpMyAdmin
--> Processing Dependency: php-mysql >= 4.1.0 for package: phpMyAdmin
--> Processing Dependency: php >= 4.1.0 for package: phpMyAdmin
--> Processing Dependency: php-mbstring >= 4.1.0 for package: phpMyAdmin
--> Running transaction check
---> Package php.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php
--> Processing Dependency: php-cli = 5.1.6-27.el5_5.3 for package: php
---> Package php-mbstring.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-mcrypt.x86_64 0:5.1.6-5.el5 set to be updated
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt
---> Package php-mysql.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-pdo for package: php-mysql
--> Running transaction check
---> Package libmcrypt.x86_64 0:2.5.7-5.el5 set to be updated
---> Package php-cli.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-common.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-pdo.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-1.el5_6.1.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common

Rainer


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]