[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RHEL 5.6 and PHP 5.3



Once upon a time, Rainer Traut <tr ml gmx de> said:
> Am 23.03.2011 02:36, schrieb Chris Adams:
> >Now that RHEL 5.6 has added PHP 5.3 (php53-* packages), is there any
> >plan on what to do with the EPEL PHP packages?  If I did my query right,
> >it looks like the following EPEL packages are built for PHP 5.1 only (by
> >source RPM):
> >
> >    libpuzzle
> >    php-extras
> >    php-facedetect
> >    php-idn
> >    php-magickwand
> >    php-pecl-Fileinfo
> >    php-pecl-geoip
> >    php-pecl-gmagick
> >    php-pecl-imagick
> >    php-pecl-json
> >    php-pecl-lzf
> >    php-pecl-mailparse
> >    php-pecl-mongo
> >    php-pecl-radius
> >    php-pecl-runkit
> >    php-pecl-xdebug
> >    php-pecl-zip
> >
> 
> I think phpMyAdmin has the same problem:

The problem is not phpMyAdmin itself (it doesn't require a specific
version of PHP), but php-mcrypt (which comes from php-extras, listed
above).

Oh wait, also anything with a Requires like "php-mysql >= 4.1.0" won't
work, because the RHEL php53-mysql package doesn't provide "php-mysql".
The RHEL php53 package doesn't even provide "php", so all kinds of
dependencies are going to fail.

Anybody have any ideas on how to untangle this?  Is it going to even be
possible to use EPEL PHP packages with RHEL 5.6 PHP 5.3?
-- 
Chris Adams <cmadams hiwaay net>
Systems and Network Administrator - HiWAAY Internet Services
I don't speak for anybody but myself - that's enough trouble.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]