[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora EPEL 5 updates-testing report



The following Fedora EPEL 5 Security updates need testing:

    https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0715/python-sqlalchemy0.5-0.5.8-9.el5
    https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0727/python-sqlalchemy-0.3.11-2.el5
    https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0697/libarchive-2.8.4-5.el5
    https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0352/bugzilla-3.2.10-4.el5
    https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0768/php-pear-CAS-1.3.0-2.el5
    https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0809/nginx-0.8.55-2.el5


The following builds have been pushed to Fedora EPEL 5 updates-testing

    nginx-0.8.55-2.el5
    perl-Data-Section-0.101621-2.el5
    perl-Module-CPANTS-Analyse-0.85-11.el5
    perl-PPI-1.201-2.el5
    perl-Params-Util-1.00-3.el5
    perl-Perl-MinimumVersion-1.20-3.el5
    perl-Software-License-0.103004-2.el5
    perl-Sub-Exporter-0.982-11.el5

Details about builds:


================================================================================
 nginx-0.8.55-2.el5 (FEDORA-EPEL-2012-0809)
 Robust, small and high performance HTTP and reverse proxy server
--------------------------------------------------------------------------------
Update Information:

Fixes	 CVE-2012-1180
--------------------------------------------------------------------------------
ChangeLog:

* Sat Mar 17 2012 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.8.55-2
- patch for CVE-2012-1180
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #803856 - CVE-2012-1180 nginx: malformed HTTP response headers leads to information leak
        https://bugzilla.redhat.com/show_bug.cgi?id=803856
--------------------------------------------------------------------------------


================================================================================
 perl-Data-Section-0.101621-2.el5 (FEDORA-EPEL-2012-0807)
 Read multiple hunks of data out of your DATA section
--------------------------------------------------------------------------------
Update Information:

This is the first EPEL-5 release of perl-Data-Section.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #461303 - Review Request: perl-Data-Section - Read multiple hunks of data out of your DATA section
        https://bugzilla.redhat.com/show_bug.cgi?id=461303
--------------------------------------------------------------------------------


================================================================================
 perl-Module-CPANTS-Analyse-0.85-11.el5 (FEDORA-EPEL-2012-0805)
 Generate Kwalitee ratings for a distribution
--------------------------------------------------------------------------------
Update Information:

This is the first EPEL-5 release of perl-Module-CPANTS-Analyse.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #426542 - Review Request: perl-Module-CPANTS-Analyse - Generate Kwalitee ratings for a distribution
        https://bugzilla.redhat.com/show_bug.cgi?id=426542
--------------------------------------------------------------------------------


================================================================================
 perl-PPI-1.201-2.el5 (FEDORA-EPEL-2012-0803)
 Parse, Analyze and Manipulate Perl
--------------------------------------------------------------------------------
Update Information:

This update includes a host of bug-fixes and enhancements:

* Improved lexing correctness
* Partial implementation of literal
* Initial implementation of Number classes
* Fixed various regression cases
* Fixed some parser corner cases
* Added parser timeout support
* Added some housekeeping tweaks
* Support for a few more rare/legacy Perl syntax
* Tokenizer simplification, optimization and exception'ification
* Various small bug fixes

--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #803301 - RFE: update to at least 1.201
        https://bugzilla.redhat.com/show_bug.cgi?id=803301
--------------------------------------------------------------------------------


================================================================================
 perl-Params-Util-1.00-3.el5 (FEDORA-EPEL-2012-0801)
 Simple standalone param-checking functions
--------------------------------------------------------------------------------
Update Information:

This update brings a host of bug-fixes and enhancements, plus one incompatible change: the long-deprecated `_CALLABLE` function has been removed; any code still using this function should change `_CALLABLE` to `_CODELIKE`, which will not only get the code working again, it'll get rid of the deprecation warnings too.

* Added the `_NONNEGINT` function
* Removed the deprecated `_CALLABLE` function
* Added XS implementation for much-improved performance
* Fixed the overload for `_REGEX`
* Fixed `_IDENTIFIER` to return false for "`foo\n`"
* Fixed `_CLASS` to return false for "`foo\n`"
* Various test suite fixes

--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #803307 - RFE: update to at least 0.38
        https://bugzilla.redhat.com/show_bug.cgi?id=803307
--------------------------------------------------------------------------------


================================================================================
 perl-Perl-MinimumVersion-1.20-3.el5 (FEDORA-EPEL-2012-0802)
 Find a minimum required version of perl for Perl code
--------------------------------------------------------------------------------
Update Information:

This is the first EPEL-5 release of perl-Perl-MinimumVersion.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #392271 - Review Request:  perl-Perl-MinimumVersion -  Find a minimum required version of perl
        https://bugzilla.redhat.com/show_bug.cgi?id=392271
--------------------------------------------------------------------------------


================================================================================
 perl-Software-License-0.103004-2.el5 (FEDORA-EPEL-2012-0799)
 Package that provides templated software licenses
--------------------------------------------------------------------------------
Update Information:

This is the first EPEL-5 release of perl-Software-License.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #461307 - Review Request: perl-Software-License Packages that provide templated software licenses
        https://bugzilla.redhat.com/show_bug.cgi?id=461307
--------------------------------------------------------------------------------


================================================================================
 perl-Sub-Exporter-0.982-11.el5 (FEDORA-EPEL-2012-0808)
 Sophisticated exporter for custom-built routines
--------------------------------------------------------------------------------
Update Information:

This update, to the current upstream release from CPAN, includes bug fixes:

* Fixed merge_col, which was not updated to work with \name generators
* Fixed inadvertent futzing with group generator args (CPAN RT#38885)
* Fixed very occasional hash ordering issue in tests

Enhancements:

* Major refactoring of the core generation/installation code, and tentative interface documentation for replacing it
* Collector hooks can now alter @_ to replace the value to be collected
* Clarified args passed to generator in Tutorial
* Improved documentation of new installer/generator options
* Added INIT collector
* Declared reservation of all CAPS collectors
* Clarified documentation of -setup
* Fixed typo in SYNOPSIS

Deprecations:

* Calling "installer" the "exporter" is no longer supported; no packages in EPEL-5 are affected by this

--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #799993 - RFE: update to at least 0.979
        https://bugzilla.redhat.com/show_bug.cgi?id=799993
--------------------------------------------------------------------------------



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]