[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RFC: Rethinking EPEL at FUDcon Lawrence 2013



On 11/22/2012 11:40 AM, Jan Pazdziora wrote:
> Yes. And that's the point -- if you have php53 installed, it should
> not be easy for you to shoot yourself to the foot to by upgrading to
> php54 or php == 5.5 or something. You probably moved to php53 to stay
> on that version.
Yes.

Given you have php53 installed and an application which requires php53.
Then a newer version of your application is released to EPEL, now
requiring php55, as php >= 5.5 (and also implicitly php55-mysql55 and
also php55-ldap) which where previously installed as their php53
counterparts. The point is, this makes it a real pain to upgrade each
package individually, because dependencies can't be solved automatically.

Using requirements php55 as opposite to requires php >= 5.5 for the
above application is nonsense, but would you enable to solve
dependencies. You're introducing several packages providing the same
capability. Is yum's dependency resolver capable to solve that
deterministic? What about other updaters?
-- 
Matthias Runge <mrunge matthias-runge de>
               <mrunge fedoraproject org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]