[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [et-mgmt-tools] converting full to para



I was using this process a few months back. Most likely what's happening is that it's missing the disk controller modules in the in initrd so it's not able to find your logical volumes. You'll will need to update your /etc/modprobe.conf to use the paravirt modules (xennet/xenblk) then rebuild the initrd. Should boot at that point.

Paras pradhan wrote:
virt-p2v was able to convert my centOS 5.2 physical machine to xen virtual machine and it runs great. Now, I am working on to convert this full virt machine to para virt .

Under my domU i have installed kernel-xen (since it is needed ) , and edited my grub menu to use the installed kernel.
My grub menu file in domU looks like:

----
kernel /vmlinuz-2.6.18-92.1.17.el5xen ro root=/dev/VolGroup00/LogVol00 rhgb quiet initrd /initrd-2.6.18-92.1.17.el5xen.img ----

Here is my config file that I have used (for para):

-----
name = "localhost_localdomain"
uuid = "a57400f11c2138ec41087b80e813496e"
maxmem = 512
memory = 512
vcpus = 1
bootloader = "/usr/bin/pygrub"
disk = [ "file:/freespace/p2v-localhost_localdomain-200811061823-hda.img,hda,w" ]
vif = [ "mac=00:16:3e:e6:3b:e2" ]
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
#keymap = "en-us"
#serial = "pty"
extra = "xencons=tty"
bootloader = "/usr/bin/pygrub"
vfb = [  ]
vif = [ "mac=00:16:3e:17:03:9f,bridge=xenbr0" ]
----


The error I am getting is:

--

[root ha2 xen]# xm create /etc/xen/localhost_localdomain -c
Using config file "/etc/xen/localhost_localdomain".
Started domain localhost_localdomain
PCI: Fatal: No PCI config space access function found
rtc: IRQ 8 is not free.
PCI: Fatal: No PCI config space access function found
rtc: IRQ 8 is not free.
i8042.c: No controller found.
Red Hat nash version 5.1.19.6 <http://5.1.19.6> starting
  Reading all physical volumes.  This may take a while...
  No volume groups found
  Volume group "VolGroup00" not found
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!
---



Any help will be appreciated.

Thanks !
Paras.


------------------------------------------------------------------------

_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools redhat com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]