[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Do not BuildRequires: glibc-kernheaders



The glibc-kernheaders packages provides 'kernel-headers'. If you need to
require a specific _version_, you should use that.

But if you just need to require that it exists, you don't need to do
anything -- the standard gcc development packages depend on it.

If there's a file missing from /usr/include/linux or /usr/include/asm
when you try to build, that's either a bug in the glibc-kernheaders
package, or a bug in the package you're trying to build. If it's a
kernel header you _should_ be using from userspace, assume the former
and file a bug against glibc-kernheaders. If the latter, fix it not to
include kernel headers.

Do _NOT_ add 'BuildRequires: glibc-kernheaders' to any packages. That
will break. Soon.

-- 
dwmw2


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]