[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Names for icons that are not on the Tango list...



On Tue, 2006-08-08 at 15:54 -0400, Diana Fong wrote:
> I created a couple of icons that were not on the Tango list...and so 
> made up my own names accordingly.  Examples include: 
> drive-harddisk-usb/firewire, drive-removable-usb/firewire, 
> format-justify-last-left, format-justify-last-right...etc.  Hopefully 
> they're ok. 
> 
> Is there a more comprehensive list somewhere that I haven't found or 
> could these extra names be submitted somewhere to Tango to help maintain 
> consistency.  I saw this link with the "Icon Naming Specifications" [1] 
> which is not equal to the "Icon Metaphors" list [2]. 

The icon-naming-spec is, to put it nicely (in fact he is being a total
jerk), wary of adding e.g. drive-harddisk-usb to the spec and is
actively rejecting patches to fix it. See the full thread here

 http://mail.gnome.org/archives/desktop-devel-list/2006-July/msg00797.html

Suggest to use the old names [1] as the software (gnome-vfs) using these
icons still expect the old names and we're just not going to change
until said maintainer smartens up. 

FYI, I plan to try to work with dobey (the icon-naming-spec maintainer)
and other stakeholders in the community (e.g. KDE people) through the
work I'm doing on HAL. Will keep you posted when I know more.

[1] : Can be found in this source file - it's in the array called
"hal_icon_mapping[]" just a few pages down

 http://cvs.gnome.org/viewcvs/gnome-vfs/libgnomevfs/gnome-vfs-hal-mounts.c?rev=1.34&view=markup


> Lastly...I've made battery icons for PowerManager but the naming scheme 
> is nowhere to be found on Tango.  I was pointed to [3] but the names 
> seems different to what might fit in the Tango naming scheme. 

Yes, I'm pretty sure Richard Hughes, g-p-m maintainer, will refuse to
cripple his software just becase the icon-naming-spec maintainer has
this odd idea that only 'battery-caution', 'battery-low' and 'battery'
should be used by g-p-m. I could be wrong (hope I'm not!), so I've Cc'ed
Richard on this mail - Richard, can you confirm that g-p-m will stick to
the gpm-* icons you already use?

Thanks,
David



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]