[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/openoffice.org/devel openoffice.org.spec,1.313,1.314



Author: caolanm

Update of /cvs/dist/rpms/openoffice.org/devel
In directory cvs.devel.redhat.com:/tmp/cvs-serv3396

Modified Files:
	openoffice.org.spec 
Log Message:
spec cleanups


Index: openoffice.org.spec
===================================================================
RCS file: /cvs/dist/rpms/openoffice.org/devel/openoffice.org.spec,v
retrieving revision 1.313
retrieving revision 1.314
diff -u -r1.313 -r1.314
--- openoffice.org.spec	15 Jul 2005 18:16:42 -0000	1.313
+++ openoffice.org.spec	15 Jul 2005 21:40:48 -0000	1.314
@@ -15,10 +15,12 @@
 %if %{build_fc4}
 %define release_extension .1.0.fc4
 %define internalxmlsec 1
+%define internaldb 1
 %endif
 %if %{build_fc5}
 %define release_extension .2.0.fc5
 %define internalxmlsec 0
+%define internaldb 1
 %endif
 
 %if %{usegcc3}
@@ -38,13 +40,19 @@
 else
 %define xmlsecflags --with-system-xmlsec
 %endif
-
+%if %{internaldb}
+%define dbflags --without-system-db
+else
+%define dbflags --with-system-db
+%endif
 %if %{stlvisibilityfcked}
-%define extraflags %{xmlsecflags}
+%define stlflags --with-stlport4
 %else
-%define extraflags %{xmlsecflags} --without-stlport4
+%define stlflags --without-stlport4
 %endif
 
+%define extraflags %{xmlsecflags} %{dbflags} %{stlflags}
+
 %if %{includeexternals}
 # Disable internal dependency generator while we include libxmlsec1 and
 # other similiar duplicate/conflicting libs rh#156039#
@@ -72,7 +80,7 @@
 Source2:	openoffice.org-myspell-contrib.tar.gz
 Source3:	GSI_ta-IN.sdf
 Source4:	openoffice.org-simple-crash_report.sh
-BuildRequires: 	perl, sed, zip, bzip2, unzip, tar, findutils
+BuildRequires: 	tcsh, perl, sed, zip, bzip2, unzip, tar, findutils
 BuildRequires: 	autoconf, make >= 3.79.1, ant, flex, bison, perl-Compress-Zlib
 BuildRequires: 	gcc >= 3.4.3, gcc-c++ >= 3.4.3, binutils
 BuildRequires:  %{gccjava} >= 4.0.0, %{libgcjdevel} >= 4.0.0
@@ -82,7 +90,7 @@
 BuildRequires: 	boost-devel >= 1.31.0, python-devel, mozilla-devel >= 1.7.5
 BuildRequires: 	expat-devel, libxml2-devel, openldap-devel, neon-devel >= 0.24 
 BuildRequires: 	libidn-devel, startup-notification-devel, libwpd-devel >= 0.8.0
-BuildRequires:	desktop-file-utils >= 0.9, libjpeg-devel, pam-devel, tcsh
+BuildRequires:	desktop-file-utils >= 0.9, libjpeg-devel, pam-devel
 BuildRequires:	perl-Archive-Zip, evolution-data-server-devel, libxslt >= 1.1.14
 %if ! %{internalxmlsec}
 BuildRequires:	xmlsec1-nss-devel >= 1.2.8-2
@@ -779,9 +787,7 @@
 %patch55 -p1 -b .ooo51745.cpputools.patch
 %patch56 -p1 -b .ooo51755.scp2.parallel.patch
 %patch57 -p1 -b .ooo51774.rsc.parallel.patch
-%if %{build_fc5}
 %patch58 -p1 -b .oooXXXXX.extensions.evolution.patch
-%endif
 %patch59 -p1 -b .workspace.impress63.patch
 %patch60 -p1 -b .rh163147.thorndale.fontconfig.patch
 %patch61 -p1 -b .ooo51912.nullpointer.wizards.patch


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]