[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/eclipse/devel eclipse.spec,1.171,1.172



Author: overholt

Update of /cvs/dist/rpms/eclipse/devel
In directory cvs.devel.redhat.com:/tmp/cvs-serv28364

Modified Files:
	eclipse.spec 
Log Message:
* Tue Jul 19 2005 Andrew Overholt <overholt redhat com> 3.1.0_fc-7
- Remove ant-jmf symlinking and requirement.
- Update to use java-gcj-compat and not java-1.4.2-gcj-compat.



Index: eclipse.spec
===================================================================
RCS file: /cvs/dist/rpms/eclipse/devel/eclipse.spec,v
retrieving revision 1.171
retrieving revision 1.172
diff -u -r1.171 -r1.172
--- eclipse.spec	14 Jul 2005 21:29:47 -0000	1.171
+++ eclipse.spec	19 Jul 2005 19:47:18 -0000	1.172
@@ -24,7 +24,7 @@
 Summary:        %{pkg_summary}
 Name:           eclipse
 Version:        %{eclipse_majmin}.%{eclipse_micro}_fc
-Release:        6
+Release:        7
 License:        EPL
 Group:          Text Editors/Integrated Development Environments (IDE)
 URL:            http://www.eclipse.org/
@@ -100,7 +100,7 @@
 %if %{gcj_support}
 ExclusiveArch: %{ix86} x86_64 ppc
 %else
-BuildArch:     noarch
+BuildArch:	noarch
 %endif
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 BuildRequires:  ant
@@ -118,7 +118,7 @@
 %endif
 %if %{gcj_support}
 BuildRequires:	gcc-java >= 4.0.1
-BuildRequires:	java-1.4.2-gcj-compat-devel >= 1.4.2.0-40jpp_37rh
+BuildRequires:	java-gcj-compat-devel >= 1.0.33
 BuildRequires:  dos2unix
 %else
 BuildRequires:	java-devel >= 1.4.2
@@ -126,7 +126,7 @@
 
 BuildRequires: ant-antlr ant-apache-bcel ant-apache-bsf ant-apache-log4j ant-apache-oro ant-apache-regexp ant-apache-resolver ant-commons-logging
 #BuildRequires: ant-commons-net
-BuildRequires: ant-javamail ant-jdepend ant-jmf ant-junit ant-nodeps ant-swing ant-trax ant-jsch
+BuildRequires: ant-javamail ant-jdepend ant-junit ant-nodeps ant-swing ant-trax ant-jsch
 BuildRequires: jsch >= 0:0.1.18-1jpp
 BuildRequires: jakarta-commons-beanutils jakarta-commons-collections jakarta-commons-digester jakarta-commons-dbcp jakarta-commons-el jakarta-commons-fileupload jakarta-commons-launcher jakarta-commons-logging jakarta-commons-modeler jakarta-commons-pool
 BuildRequires: mx4j >= 2.1
@@ -135,7 +135,10 @@
 BuildRequires: regexp 
 BuildRequires: junit >= 3.8.1-3jpp
 %if %{gcj_support}
-Requires(post,postun): java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_37rh
+BuildRequires:  gcc-java >= 4.0.1
+BuildRequires:    java-gcj-compat-devel >= 1.0.33
+Requires(post):   java-gcj-compat >= 1.0.33
+Requires(postun): java-gcj-compat >= 1.0.33
 %endif
 
 %description
@@ -151,7 +154,8 @@
 Provides:	ecj
 %if %{gcj_support}
 Requires:	libgcj >= 4.0.1
-Requires(post,postun): java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_37rh
+Requires(post):	java-gcj-compat >= 1.0.33
+Requires(postun): java-gcj-compat >= 1.0.33
 %else
 Requires:	java >= 1.4.2
 %endif
@@ -169,9 +173,10 @@
 Provides:       %{name}-scripts = %{epoch}:%{version}-%{release}
 Provides:       %{name}-gtk2 = %{epoch}:%{version}-%{release}
 %if %{gcj_support}
-Requires:	java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_37rh
 Requires:	libgcj >= 4.0.1
-Requires(post,postun): java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_37rh
+Requires:	java-gcj-compat >= 1.0.33
+Requires(post):   java-gcj-compat >= 1.0.33
+Requires(postun): java-gcj-compat >= 1.0.33
 %else
 Requires:	java >= 1.4.2
 %endif
@@ -184,7 +189,7 @@
 
 Requires: ant-antlr ant-apache-bcel ant-apache-bsf ant-apache-log4j ant-apache-oro ant-apache-regexp ant-apache-resolver ant-commons-logging
 #Requires: ant-commons-net
-Requires: ant-javamail ant-jdepend ant-jmf ant-junit ant-nodeps ant-swing ant-trax ant-jsch
+Requires: ant-javamail ant-jdepend ant-junit ant-nodeps ant-swing ant-trax ant-jsch
 Requires: jsch >= 0:0.1.18-1jpp
 Requires: jakarta-commons-beanutils jakarta-commons-collections jakarta-commons-digester jakarta-commons-dbcp jakarta-commons-el jakarta-commons-fileupload jakarta-commons-launcher jakarta-commons-logging jakarta-commons-modeler jakarta-commons-pool
 Requires: mx4j >= 2.1
@@ -212,7 +217,8 @@
 Requires:       junit >= 3.8.1-3jpp
 %if %{gcj_support}
 Requires:	libgcj >= 4.0.1
-Requires(post,postun): java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_37rh
+Requires(post):   java-gcj-compat >= 1.0.33
+Requires(postun): java-gcj-compat >= 1.0.33
 %endif
 
 %description    jdt
@@ -232,8 +238,9 @@
 Requires:       %{name}-jdt = %{epoch}:%{version}-%{release}
 Requires:       %{name}-platform-devel = %{epoch}:%{version}-%{release}
 %if %{gcj_support}
-Requires(post,postun): java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_37rh
 Requires:	libgcj >= 4.0.1
+Requires(post):   java-gcj-compat >= 1.0.33
+Requires(postun): java-gcj-compat >= 1.0.33
 %endif
 
 %package        pde-devel
@@ -254,8 +261,9 @@
 Summary:        SWT Library for GTK2
 Group:          Text Editors/Integrated Development Environments (IDE)
 %if %{gcj_support}
-Requires(post,postun): java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_37rh
 Requires:	libgcj >= 4.0.1
+Requires(post):   java-gcj-compat >= 1.0.33
+Requires(postun): java-gcj-compat >= 1.0.33
 %endif
 
 %description -n %{libname}-gtk2
@@ -266,7 +274,8 @@
 Group:          Development/Languages
 %if %{gcj_support}
 Requires:	libgcj >= 4.0.1
-Requires(post,postun): java-1.4.2-gcj-compat >= 1.4.2.0-40jpp_37rh
+Requires(post):   java-gcj-compat >= 1.0.33
+Requires(postun): java-gcj-compat >= 1.0.33
 %else
 Requires:	java >= 1.4.2
 %endif
@@ -385,7 +394,7 @@
 #ln -sf %{_javadir}/ant.jar plugins/org.apache.ant/lib/ant.jar
 ln -sf %{_javadir}/ant/ant-javamail.jar plugins/org.apache.ant/lib/ant-javamail.jar
 ln -sf %{_javadir}/ant/ant-jdepend.jar plugins/org.apache.ant/lib/ant-jdepend.jar
-ln -sf %{_javadir}/ant/ant-jmf.jar plugins/org.apache.ant/lib/ant-jmf.jar
+#ln -sf %{_javadir}/ant/ant-jmf.jar plugins/org.apache.ant/lib/ant-jmf.jar
 ln -sf %{_javadir}/ant/ant-jsch.jar plugins/org.apache.ant/lib/ant-jsch.jar
 ln -sf %{_javadir}/ant/ant-junit.jar plugins/org.apache.ant/lib/ant-junit.jar
 ln -sf %{_javadir}/ant-launcher.jar plugins/org.apache.ant/lib/ant-launcher.jar
@@ -745,7 +754,7 @@
 #ln -sf %{_javadir}/ant.jar plugins/org.apache.ant_*/lib/ant.jar
 ln -sf %{_javadir}/ant/ant-javamail.jar plugins/org.apache.ant_*/lib
 ln -sf %{_javadir}/ant/ant-jdepend.jar plugins/org.apache.ant_*/lib/ant-jdepend.jar
-ln -sf %{_javadir}/ant/ant-jmf.jar plugins/org.apache.ant_*/lib/ant-jmf.jar
+#ln -sf %{_javadir}/ant/ant-jmf.jar plugins/org.apache.ant_*/lib/ant-jmf.jar
 ln -sf %{_javadir}/ant/ant-jsch.jar plugins/org.apache.ant_*/lib/ant-jsch.jar
 ln -sf %{_javadir}/ant/ant-junit.jar plugins/org.apache.ant_*/lib/ant-junit.jar
 ln -sf %{_javadir}/ant-launcher.jar plugins/org.apache.ant_*/lib/ant-launcher.jar
@@ -821,20 +830,16 @@
   $RPM_BUILD_ROOT%{_datadir}/java/eclipse-ecj.jar
 
 %if %{gcj_support}
-aot-compile-rpm --exclude /usr/share/eclipse/plugins/org.eclipse.osgi_3.1.0.jar
-
 # FIXME:  temporarily disable org.eclipse.ui.forms_3.1.0.jar.so 
 # see:  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=146463
-rm -f $RPM_BUILD_ROOT%{_libdir}/gcj/%{name}/org.eclipse.ui.forms_3.1.0.jar.db
-rm -f $RPM_BUILD_ROOT%{_libdir}/gcj/%{name}/org.eclipse.ui.forms_3.1.0.jar.so
 # FIXME:  temporarily disable org.eclipse.ui.workbench_3.1.0.jar.so
 # see:  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=151919
-rm -f $RPM_BUILD_ROOT%{_libdir}/gcj/%{name}/org.eclipse.ui.workbench_3.1.0.jar.so
-rm -f $RPM_BUILD_ROOT%{_libdir}/gcj/%{name}/org.eclipse.ui.workbench_3.1.0.jar.db
 # FIXME:  temporarily disable org.eclipse.osgi_3.1.0.jar.so
 # see: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=158137
-rm -f $RPM_BUILD_ROOT%{_libdir}/gcj/%{name}/org.eclipse.osgi_3.1.0.jar.so
-rm -f $RPM_BUILD_ROOT%{_libdir}/gcj/%{name}/org.eclipse.osgi_3.1.0.jar.db
+aot-compile-rpm \
+--exclude %{_libdir}/%{name}/plugins/org.eclipse.ui.workbench_%{eclipse_majmin}.%{eclipse_micro}.jar \
+--exclude %{_libdir}/%{name}/plugins/org.eclipse.ui.forms_%{eclipse_majmin}.%{eclipse_micro}.jar \
+--exclude %{_libdir}/%{name}/plugins/org.eclipse.osgi_%{eclipse_majmin}.%{eclipse_micro}.jar
 
 # Build and install ecj binary
 pushd $RPM_BUILD_ROOT%{_libdir}/gcj/%{name}
@@ -1156,6 +1161,10 @@
 %{_datadir}/%{name}/plugins/org.eclipse.platform.source.linux.gtk.*_3.1.0
 
 %changelog
+* Tue Jul 19 2005 Andrew Overholt <overholt redhat com> 3.1.0_fc-7
+- Remove ant-jmf symlinking and requirement.
+- Update to use java-gcj-compat and not java-1.4.2-gcj-compat.
+
 * Tue Jul 12 2005 Andrew Overholt <overholt redhat com> 3.1.0_fc-6
 - Bump release to build against new gcc.
 - Bump gcc requirement to gcc 4.0.1.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]