[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Dependency hell



Please see the list of my attempts to update my system to rawhide. The thing that seems most incorrect is that rpm or yum do not report correctly the packages that need to be excluded. Since there always seems to be some dependency problem (one gets fixed but another one stops the update) it would seem that a reliable way to determine which packages to exclude would be very helpful and save time that can be put to better use. thanks for any help,
Richard Hally




[root localhost root]# yum upgrade
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Rawhide
Finding updated packages
Downloading needed headers
Finding obsoleted packages
Resolving dependencies
......Unable to satisfy dependencies
Package pwlib needs libdv.so.2, this is not available.
Package xemacs needs libRKC.so.1.2, this is not available.
Package xemacs needs libcanna.so.1.2, this is not available.
Package dvgrab needs libdv.so.2, this is not available.
Package db4-java needs db4 = 4.1.25-14, this is not available.

Here is the second attempt with the packages that reported excluded



[root localhost root]# yum --exclude=pwlib --exclude=xemacs --exclude=dvgrab --exclude=db4-java upgrade
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Rawhide
Finding updated packages
Downloading needed headers
Finding obsoleted packages
Resolving dependencies
......Unable to satisfy dependencies
Package gnomemeeting needs libpt.so.1.6.3, this is not available.
Package gnomemeeting needs pwlib >= 1.6.3, this is not available.
Package xemacs-info needs xemacs = 21.4.15, this is not available.
Package openh323 needs libpt.so.1.6.3, this is not available.
Package openh323 needs pwlib >= 1.6.3, this is not available.
Package xemacs-el needs xemacs = 21.4.15, this is not available.
Package pwlib-devel needs libpt.so.1.6.3, this is not available.
Package pwlib-devel needs pwlib = 1.6.3, this is not available.
Package db4-java needs db4 = 4.1.25-14, this is not available.
[root localhost root]#






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]