[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dependency hell



Andrew Farris wrote:

On Fri, 2004-04-02 at 21:26 -0500, Richard Hally wrote:



Please see the list of my attempts to update my system to rawhide. The thing that seems most incorrect is that rpm or yum do not report correctly the packages that need to be excluded. Since there always seems to be some dependency problem (one gets fixed but another one stops the update) it would seem that a reliable way to determine which packages to exclude would be very helpful and save time that can be put to better use. thanks for any help,
Richard Hally






[root localhost root]# yum upgrade


<snip>


Package pwlib needs libdv.so.2, this is not available.
Package xemacs needs libRKC.so.1.2, this is not available.
Package xemacs needs libcanna.so.1.2, this is not available.
Package dvgrab needs libdv.so.2, this is not available.
Package db4-java needs db4 = 4.1.25-14, this is not available.


<snip>


[root localhost root]# yum --exclude=pwlib --exclude=xemacs --exclude=dvgrab --exclude=db4-java upgrade



You have, like so many others, misunderstood the statements: they are not telling you what packages are not available, they are telling you what files are no longer available (due to the new version being installed--libraries are being removed/updated).

libdv.so.2 is being removed, the new version of libdv does NOT supply
it, likewise for the other files mentioned.  This is accurately telling
you what files are no longer present after the test upgrade (dependency
tests).

You should have instead excluded the library packages that were being
changed, not the packages you already have that require the old library
files.  What you did was to exclude packages which you already have
installed--essentially doing nothing.

You may need to remove db4-java since that package requires an old
library (or find the update to it which should be built properly against
the new library).
yum --exclude=libdv* --exclude=Canna-lib* --exclude=db4 update


Thank you Andrew, you make my point for me in an indrect way. It takes four paragraphs to try to explain what is going on and it is still as clear as mud(no slam on your excellent exposition). I just want it to tell me what packages to exclude, that's all. :)
But, to extend the instance, the result of your suggested yum command line is shown below:
(I have installed apt since the previous attempt with yum (of course that just adds to the problem))
Isn't that just wonderful...and it goes on, rpm-4.2.1-0.30 is installed and provides librpm-4.2.so
but of course yum/rpm doesn't say it will not be available if I do this update, it says *is not *available. should I add --exclude=rpm --exclude=python2.2
I guess I have belabored the point, sorry


Thanks for your help,
Richard Hally
[root localhost root]# yum --exclude=libdv* --exclude=Canna-lib --exclude=db4 update
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Rawhide
Finding updated packages
Downloading needed headers
Resolving dependencies
.Package apt needs librpm-4.2.so, this is not available.
Package apt needs librpmdb-4.2.so, this is not available.
Package apt needs librpmio-4.2.so, this is not available.
Package db4-java needs db4 that has been excluded.
Package redhat-config-network-tui needs /usr/bin/python2.2, this is not available.
Package redhat-config-users needs /usr/bin/python2.2, this is not available.
Package redhat-config-nfs needs /usr/bin/python2.2, this is not available.
Package redhat-config-language needs /usr/bin/python2.2, this is not available.
Package redhat-config-xfree86 needs /usr/bin/python2.2, this is not available.
Package redhat-config-kickstart needs /usr/bin/python2.2, this is not available.Package redhat-config-date needs /usr/bin/python2.2, this is not available.
Package redhat-config-keyboard needs /usr/bin/python2.2, this is not available.
Package redhat-config-mouse needs /usr/bin/python2.2, this is not available.
Package redhat-config-securitylevel needs /usr/bin/python2.2, this is not available.
Package redhat-config-soundcard needs /usr/bin/python2.2, this is not available.Package redhat-config-samba needs /usr/bin/python2.2, this is not available.
Package redhat-config-bind needs /usr/bin/python2.2, this is not available.
Package redhat-config-rootpassword needs /usr/bin/python2.2, this is not available.
[root localhost root]#







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]