[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dependency hell



yes,  I have run into these issues before.  It helps to run `yum list
extras` to see which packages are installed, but are not in the yum.conf
repositories (removed in some cases such as the redhat-config-*).  I do
not think that running yum upgrade would replace the redhat-config-* with
the appropriate system-config-* packages.  Hope that idea clears up some
of the problems.  I rarely get broken package upgrading these
after-extras-removed days :) (though libdv and the ethereal bugs did just
happen, they are the exception rather than the rule I think.)
---Matt
<reactivate lurk mode>

> On Sat, 2004-04-03 at 11:02, Richard Hally wrote:
>>
>>  [root localhost root]# yum --exclude=libdv* --exclude=Canna-lib
>> --exclude=db4 update
>> Gathering header information file(s) from server(s)
>> Server: Fedora Core 1 - i386 - Rawhide
>> Finding updated packages
>> Downloading needed headers
>> Resolving dependencies
>> .Package apt needs librpm-4.2.so, this is not available.
>> Package apt needs librpmdb-4.2.so, this is not available.
>> Package apt needs librpmio-4.2.so, this is not available.
>> Package db4-java needs db4 that has been excluded.
>> Package redhat-config-network-tui needs /usr/bin/python2.2, this is not
>> available.
>> Package redhat-config-users needs /usr/bin/python2.2, this is not
>> available.
>> Package redhat-config-nfs needs /usr/bin/python2.2, this is not
>> available.
>> Package redhat-config-language needs /usr/bin/python2.2, this is not
>> available.
>> Package redhat-config-xfree86 needs /usr/bin/python2.2, this is not
>> available.
>> Package redhat-config-kickstart needs /usr/bin/python2.2, this is not
>> available.Package redhat-config-date needs /usr/bin/python2.2, this is
>> not available.
>> Package redhat-config-keyboard needs /usr/bin/python2.2, this is not
>> available.
>> Package redhat-config-mouse needs /usr/bin/python2.2, this is not
>> available.
>> Package redhat-config-securitylevel needs /usr/bin/python2.2, this is
>> not available.
>> Package redhat-config-soundcard needs /usr/bin/python2.2, this is not
>> available.Package redhat-config-samba needs /usr/bin/python2.2, this is
>> not available.
>> Package redhat-config-bind needs /usr/bin/python2.2, this is not
>> available.
>> Package redhat-config-rootpassword needs /usr/bin/python2.2, this is not
>> available.
>> [root localhost root]#
>
> All redhat-config-* packages have been superseded and obsoleted by
> system-config-* packages. I think you will need to manually remove any
> redhat-config-* package and install their equivalent system-config-*
> ones.
>
>
> --
> fedora-devel-list mailing list
> fedora-devel-list redhat com
> http://www.redhat.com/mailman/listinfo/fedora-devel-list
>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]